Author Topic: Track error  (Read 702 times)

I'm having another track error, when I go to export it gives me this error:

Assert failed! ..\Library\blib\src\btoolcore\CreateAiData.cpp(283): "startZ <= 0.f" 0.000000

I know that the numbers is how far I have to move it, but its 0.

EDIT: I am using Blender


  • Posts: 753
According to wiki, CreateAiData.cpp (283): "startZ <= 0.f" could be...

- Caused by the first AI sector being ahead of the starting positions. Make sure your first AI sector encapsulates the rear most starting positions
- This error can also be caused due to track rotation. Rotate the track 180 degrees and ensure the error doesn't still happen.

Not sure if it was that same error, but once I really had to rotate the whole scene in blender to export without an error. If the AI sectors are ok, it's worth a try.

That worked and now it compiles but it crashes upon loading in-game. Anyone have any idea or is there a debug file?

EDIT: Adding checkpoints fixed that but now my problem is that textures aren't showing up. Im using blender and ive done them all correctly.
« Last Edit: September 04, 2017, 11:14:53 PM by TheButterApple24 »