Author Topic: bgeometry crash after generating collisions spheres  (Read 461 times)

Halal Meats

  • Posts: 39
Hey everyone,

So far I am decently through converting my first car, but bgeometry keeps crashing after generating collisions spheres. I'm not sure what is wrong because there is no error, it literally just stops working.

I don't have any of those little flag/node/joint things they put in the file yet, that is my only guess so far. There are also no textures yet, but I don't think that is it because that wasn't an issue when I tried to bring the CTR in earlier. I went through and named everything like in the original, though I changed the number ordering of the collision spheres.

I attached a picture of what it outputs before the crash. It crashes before it outputs "press any key to continue . . ."

What are some other reasons this might be crashing?

Thanks

Halal Meats

  • Posts: 39
Just ran a test and this script does not work for anything at all. Tried it with the example car and it crashed again.

How exactly are you supposed to use this? I know my way around the command prompt, I mean like is it location dependent? Do I have to use it from the tools folder? I used it last time and I don't remember it breaking quite this bad.

Halal Meats

  • Posts: 39
Checked the logs...

----------------------------------- Log created on Wed Feb 14 22:17:47 2018 ---------------------------------
..\Library\blib\src\btoolcore\BgoImporter.cpp(702) ERROR : ERROR! C:\Program Files (x86)\Steam\steamapps\common\Bugbear Entertainment\mods\example\data\vehicle\mod_vehicle_1\art\body.BGO3 has unknown file format

.BGO3 is the correct format? What is happening?

sam223

  • *
  • Posts: 3193
you are dropping it on 'build_asset' ?
It should be inside /tools
.bgo3 should be within /vehiclechassisnamehere/art
Dell U2515H 25",  i5-4690k @4.0ghz, 8gb ram, MSI GTX 1060 6GB, 120gb SSD, 1tb HHD, win 7, G25/Ps3 pad
Online Bangers:Wreckfest - https://goo.gl/AjDHU2

Halal Meats

  • Posts: 39
I run build asset from the command prompt from the tools folder like this:

build_asset.bat ../mods/mod1/data/vehicle/mod_vehicle_2/art/body.bgo3

That is how I ran it for my original vehicle.

When I try this with the example car, the program crashes after the first output line.

Should I be dropping it on the .bgo3?

Halal Meats

  • Posts: 39
Just tried dropping it and it still crashes... Really not sure what is going on at all. It doesn't always put an error out into the log either which is confusing...

sam223

  • *
  • Posts: 3193
drop .bgo3 onto build asset
Dell U2515H 25",  i5-4690k @4.0ghz, 8gb ram, MSI GTX 1060 6GB, 120gb SSD, 1tb HHD, win 7, G25/Ps3 pad
Online Bangers:Wreckfest - https://goo.gl/AjDHU2

Halal Meats

  • Posts: 39
I tried that and it still crashes... I don't remember this happening last time. If it doesn't even work on the example, I'm not really sure what to do. Should I try re-installing everything? I doubt that will do anything but I have no idea what is going on.

Halal Meats

  • Posts: 39
Alright so it works for the example now for some reason, all I did was re-export the original max file to .BGO3 so maybe I overwrote the original .BGO3 or something...

Still crashes on mine though. I'm guessing something is missing that all the cars are required to have. With no error message this is going take a lot of debugging   :-\

Thanks for replying

sam223

  • *
  • Posts: 3193
There are quite a lot of requirements to get it to work. Position,materials,textures,custom properties,objects,dummies etc.
If your problem is collision spheres check custom properties/material of example and see if they match yours.
Dell U2515H 25",  i5-4690k @4.0ghz, 8gb ram, MSI GTX 1060 6GB, 120gb SSD, 1tb HHD, win 7, G25/Ps3 pad
Online Bangers:Wreckfest - https://goo.gl/AjDHU2