Author Topic: Custom Vehicle Error on Building  (Read 499 times)

Whenever I try to build the car, I get this error.

CommandLine: "D:\Program Files (x86)\Steam\steamapps\common\Bugbear Entertainment\tools\bgeometry.exe"  -v -vhcl -input "D:\Program Files (x86)\Steam\steamapps\common\Bugbear Entertainment\mods\TheButterAppleMod\data\vehicle\warthog\art\body.BGO3" -output "D:\Program Files (x86)\Steam\steamapps\common\Bugbear Entertainment\mods\TheButterAppleMod\data\vehicle\warthog\art\body.vhcl"
Assert failed! ..\Library\blib\src\bcollide\SoftBody.cpp(458): "0.f<c.mRestLength" SoftBody distance constraint got two identical nodes: #0 and #1.

I don't know what it means or how to fix it

sam223

  • *
  • Posts: 3294
Could be a bad model. Check there's no objects on the model with no verts.xform reset rotation and scale also (ctrl+a in blender) on everything. Set 'body' origin/pivot at (0,0,0) and set origin/pivot of everything else at center of mass of the object.
« Last Edit: February 20, 2018, 10:13:20 PM by sam223 »
Dell U2515H 25",  i5-4690k @4.0ghz, 16gb ram, MSI GTX 1060 6GB, 120/500gb SSD, 1tb HHD, win 7, G25/Logitech pad

Online Bangers:Wreckfest - https://goo.gl/AjDHU2

Could be a bad model. Check there's no objects on the model with no verts.Cform reset rotation and scale also (ctrl+a in blender) on everything. Set 'body' origin/pivot at (0,0,0) and set origin/pivot of everything else at center of mass of the object.

How would I do that in 3DSMax?
« Last Edit: February 20, 2018, 09:26:38 PM by sam223 »

sam223

  • *
  • Posts: 3294
Could be a bad model. Check there's no objects on the model with no verts.Cform reset rotation and scale also (ctrl+a in blender) on everything. Set 'body' origin/pivot at (0,0,0) and set origin/pivot of everything else at center of mass of the object.

How would I do that in 3DSMax?
Sorry was a typo before. Should have said xform reset not cform.

Xform reset is a 3dsm tool. I use blender so no idea of hotkey for it
Dell U2515H 25",  i5-4690k @4.0ghz, 16gb ram, MSI GTX 1060 6GB, 120/500gb SSD, 1tb HHD, win 7, G25/Logitech pad

Online Bangers:Wreckfest - https://goo.gl/AjDHU2

Could be a bad model. Check there's no objects on the model with no verts.Cform reset rotation and scale also (ctrl+a in blender) on everything. Set 'body' origin/pivot at (0,0,0) and set origin/pivot of everything else at center of mass of the object.

How would I do that in 3DSMax?
Sorry was a typo before. Should have said xform reset not cform.

Ok thank you, ill try it our
Xform reset is a 3dsm tool. I use blender so no idea of hotkey for it

I did the xForm thingy but it still gave me the same error

sam223

  • *
  • Posts: 3294
Did you check there were no empty objects and position pivots also?
Dell U2515H 25",  i5-4690k @4.0ghz, 16gb ram, MSI GTX 1060 6GB, 120/500gb SSD, 1tb HHD, win 7, G25/Logitech pad

Online Bangers:Wreckfest - https://goo.gl/AjDHU2

Sorry but I don't really know how to check for that

sam223

  • *
  • Posts: 3294
Me neither in max :) but for the objects just go through them all and check they actually have a mesh,delete any that dont. For the pivots youll have to google how to do it in max.
Dell U2515H 25",  i5-4690k @4.0ghz, 16gb ram, MSI GTX 1060 6GB, 120/500gb SSD, 1tb HHD, win 7, G25/Logitech pad

Online Bangers:Wreckfest - https://goo.gl/AjDHU2