Author Topic: Wheel settings get lost  (Read 575 times)

Ignatius

  • Posts: 3
The game looses the wheel settings when the game has been quit. I have to re-enter all the controls at any start of the game, e.g. steering, gears and camera view. The settings of the keyboard, pedals settings (no Fanatec pedals) and the handbrake are okay. The settings are not deleted.
i7-4770K OC, Asus Z-87 Pro, 16 GB, Win 7 64bit, nVidia GTX 970 OC, Fanatec Wheel Base 2.5, VPP pedals, Fanatec handbrake

Purple44

  • *
  • Posts: 8212
Wreckfest not liking Fanatec Wheel Base 2.5 wheels yet. But v2.5 was working for about 2 weeks after update in March.

Fanatec shifter and clutch pedal will not stay bound

Fanatec csw v2.5 Wheel button configuration resetts every race

Quote from: NVR2FST;1696043263490110735
Mar 29 @ 7:40am 

FIXED !!!!

EDIT- Not Fixed

Last edited by NVR2FST; Apr 6 @ 2:42pm

So maybe permanent fix will come before final release later this year.
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

St. Jimmy

  • *
  • *
  • Posts: 1476
I posted some guide in Steam forums how to go around this problem. I remember some guy saying it worked for him. Need to find that post later. It requires you to make some file "read only" after you've set the key assignments. That way they will remain but the game will naturally crash if you try to make changes because it's "read only".
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

Paul_B

  • Posts: 258
I do recall Janne said he had no Fanatec 2.5 for testing a while back. Never had issues with Logitech or Thrustmaster wheels.

Sent from my G3311 using Tapatalk

Intel Xeon quad v3-1220@3.1ghz/ASUS Z97-A
Nvida GTX 1060 6gb/16gb HyperX ram/Windows 10/ Thrustmaster TX Leather Wheel/ Thrustmaster  T3PA Pedals / Logitech G27 Shift

Ignatius

  • Posts: 3
Thanks for all the answers, especially the thread Fanatec shifter and clutch pedal will not stay bound was helpful for me. I share the opinion that more 20 gamers are affected. Maybe Bugbear can get a test device from Fanatec, I don't know. So I hope that it could be fixed.



i7-4770K OC, Asus Z-87 Pro, 16 GB, Win 7 64bit, nVidia GTX 970 OC, Fanatec Wheel Base 2.5, VPP pedals, Fanatec handbrake

St. Jimmy

  • *
  • *
  • Posts: 1476
https://steamcommunity.com/app/228380/discussions/0/2549465882922501449/#c1620599015869427410

Quote
I've a possible workaround solution. I haven't and can't test if this works for you guys but theoretically this could work. It requires you to make a file or two read-only after you've configured your controls.

- Launch the game.
- Go in the controls.
- Set-up controls as you want them.
- After you've set up things as you like, go in the main menu so the settings are saved.
- Tab out of the game (alt+tab)
- Go in Steam's userdata folder that contains WreckFest's data. It's something like this depending on where your game is installed and your id:
C:\Program Files (x86)\Steam\userdata\<SOME_RANDOM_NUMBER>\228380\local\wreckfest early access\controllers\
- There you can find some DAT (.dat) file(s)
- Right click the file(s) -> properties - > make it read-only -> OK
- Go back in game and check again if the controls remained as you set them up.
- If everything seems to be OK, restart the game and go see again if the controls are the same.

Making that file read only after you've configured and saved your controller hopefully helps that they won't go back to default when restarting the game.

------------------------------------------------------------------------------------------------

If the above doesn't help, you could test also this file together with the above one. Warning that this makes the game crash if you go in the settings when the file below is in read-only status:

Another file that maybe could've something to do with the control settings could be the settings.sets file. If you make that file read-only, you can't configure controls and likely some other things or the game crashes. That's why you need to make it read-only after you've set-up controls and gone back to the menu. If you need to go in the settings, tab out and remove the read-only status from the file before doing any changes. After done, tab-out again and make it read-only, so the game won't make controls default again for you.


Hopefully this info can be a workaround while BB is trying to fix this. :)

Does this help you?
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

Ignatius

  • Posts: 3
It sounds completely logical. According to the time stamp of the files the changes should have been saved. I changed the read only flag of the *.dat files as well as the both settings files. But - very strange - after going back to the controls the assignments are empty again. :(
i7-4770K OC, Asus Z-87 Pro, 16 GB, Win 7 64bit, nVidia GTX 970 OC, Fanatec Wheel Base 2.5, VPP pedals, Fanatec handbrake

St. Jimmy

  • *
  • *
  • Posts: 1476
It sounds completely logical. According to the time stamp of the files the changes should have been saved. I changed the read only flag of the *.dat files as well as the both settings files. But - very strange - after going back to the controls the assignments are empty again. :(

Hmm interesting that you can even go to the settings if you've those files read only. When I wrote that, going in the settings crashed the game. ???
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR