Author Topic: Controls for wreckfest not working  (Read 989 times)

BeGPlay

  • Posts: 6
Hi,

I think I'd love to play the game, but I can't get my controls working.

Since I have to choose one of my controls I can either get my Fanatec wheelbase v2 working - steering works, but pedals not - or the Fanatec pedals v3 - pedals working, but steering not. Not to speek of key setups using button boxes and/or keyboard. PLEASE try to implement the possibility to use ALL and not only ONE of the recognized controllers.

And even when selecting keyboard the car is turning to the left by itself all the time, so I can't even use that one.

Hope you get this fixed..

Swifty

  • Posts: 9
My Fanatec v2.5 and v3 pedals work fine, But the button mapping, wheel, and pedals don't save on exit, so I need to remap and start from scratch each game start :( This needs fixing before I lose any more hair   :'(

BeGPlay

  • Posts: 6
how did you configure your controls so that they work?

BeGPlay

  • Posts: 6
I reinstalled the game and used keyboard controls only. They are not working for me. The wheel turns fully left automatically as if something would steer to the left all the time. Keyboard keys are working otherwise, but it's impossible to drive with the wheel going to the left permanently.

And the issue with the controllers remains - how can we configure various controllers at the same time instead of only one? So wheel, pedals, handbrake eg.?

Please fix it, I'd love to play the game...

St. Jimmy

  • *
  • *
  • Posts: 1516
You should be able to configure all the controllers. Just change to that controller with arrow < > signs and start to bind. You might have misunderstood that only one controller works at time. They all work at the same time.

If you're having issues try to press the "unbind all controls" or whatever it's called. Not sure does that unbind from all the controllers or just from the one you're currently looking, so you better go through every controller. When you unbind everything you can be sure that there are no conflicting ones left that are causing you issues like wheel constantly turned left.
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

BeGPlay

  • Posts: 6
Unbinding all controls helped solving the permanent steering to the left - Thank you - also for the personal reply message I received from support!

But some issues regarding controlers remain for me:

I think it is currently not possible to use hardware like Fanatec handbrake or shifter being connected via USB? At least they are not showing up as available controlers!

The steering input of my wheel does not match the wheel in the game (at all). I guess it has something to do with the number of degrees the wheel is configured with? What is correctly supported by the game? I might be able to sort that one out when I know how to configure Fanatec wheel driver to match the supported degrees in game?

There is some massive input lag between steering inputs and the in game wheel... I guess there is no way to imrpove that for me?

St. Jimmy

  • *
  • *
  • Posts: 1516
How much the visible steering wheel rotates can't be configured. I think it was something like 540 degrees what it shows if you want to 1:1 the rotation.

Too bad if those don't show. There might have been some other people also reporting problems with many USB controllers. Hopefully that can be fixed at some point.
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

Paul_B

  • Posts: 260
Check in advance settings, try 90% saturation for steering an pedals. Recently changed mine for Thrustmaster TX @900 rotation

Sent from my G3311 using Tapatalk

Intel Xeon quad v3-1220@3.1ghz/ASUS Z97-A
Nvida GTX 1060 6gb/16gb HyperX ram/Windows 10/ Thrustmaster TX Leather Wheel/ Thrustmaster  T3PA Pedals / Logitech G27 Shift

Purple44

  • *
  • Posts: 8350

But some issues regarding controlers remain for me:

I think it is currently not possible to use hardware like Fanatec handbrake or shifter being connected via USB? At least they are not showing up as available controlers!


I believe Wreckfest only "see" up to 4 USB devices. Maybe have too many?

Have you tried just plugging in the handbrake and see it Wreckfest see it when it by itself? same for shifter?
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

BeGPlay

  • Posts: 6
ah, yes, if it only sees up to 4 USB controlers then that's the reason. I have more. Sadly it sees the button boxes first which would be less important.

BeGPlay

  • Posts: 6
so setting wheel to 480 degree gives roughly the same amount of turn..

So last thing to wish  for would be support of more controlers.

And then of course triple screen support and for some others VR support.. : )

MikeJeffries

  • Posts: 2
I just posted in this forum subject also, and noticed others having similar issues. I have the same problem with a conflict between my fanatec v3 pedals and my accuforce wheel. The key bindings for the gas pedals are on the X-Axis, and accuforce wheel turns on the x-axis as well. Any way to change the axis' so there's no conflict?

Nivek

  • Posts: 1
Same hear also Thrustmaster Tx 458 wheel since latest update isn't recognised at all suddenly. Dead as a dodo. Really not impressed as it worked perfect before with my Th8A H shifter  please correct this soon bugbear as the handling is sublime with my wheel setup.... Sorry Bugbear my bad Just to add to this I've got the problem sorted now it was just my Thrustmaster firmware needed updating which does catch you unawares when it suddenly stops working for no apparent reason.
« Last Edit: June 10, 2018, 10:21:12 AM by Nivek »