Author Topic: What's up with the driving physics and steering in Multiplayer?  (Read 322 times)

St. Jimmy

  • *
  • *
  • Posts: 1523
OK this is starting to happen me pretty much always when racing in BensNCG server. Dunno why it doesn't happen often in other servers. At the beginning of the race my driving physics are all over the place and it can be bad till the end of the race. BUT if press alt+enter to go in windowed or full screen (doesn't matter, either way) it gets fixed.
But once I just dropped in dead last, press esc and closed the menu and got back to racing, the physics were OK again.

When it's wrong I've a lot of grip but I can loose the control out of a sudden. Driving from left to right feels very weird then. Rear tire spin much less and I can't go corners with rear end loose at all.

This has been an issue for a long time already, I think like a year at least. Now I know how to fix it when it happens but that isn't really too helpful to enjoy good racing... This just happens mostly on just certain servers. Some servers I can be racing with full lobby no problem, but for example Bens server I can have that issue only with a few people.

I've been today racing like 20 races in a row in Bens server and I got this issue EVERY race. I changed now to another full server and this doesn't happen at all there.
« Last Edit: June 09, 2018, 06:03:02 PM by St. Jimmy »
Official Wreckfest Discord
Unofficial  WreckFest Discord!

i7 2600K @ 4,6GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

sam223

  • *
  • Posts: 3283
alt+enter switches between full screen and full screen windowed mode. 1 mode caps the frames at either 30fps or 60fps depending on which it can surpass (with v-sync enabled). The other mode doesn't. So maybe that's the problem,game is trying to cap physics updates and frame rate to 30fps?

Alt+tab triggers a mode change,maybe using steam overlay also.
« Last Edit: June 09, 2018, 06:46:55 PM by sam223 »
Dell U2515H 25",  i5-4690k @4.0ghz, 16gb ram, MSI GTX 1060 6GB, 120/500gb SSD, 1tb HHD, win 7, G25/Logitech pad

Online Bangers:Wreckfest - https://goo.gl/AjDHU2

St. Jimmy

  • *
  • *
  • Posts: 1523
I've actually disabled vsync in this game because I've noticed it starting to make some weird input lag. I even needed to remove framerate cap from RTSS because that also started to make input laggy and the driving wasn't the same.

And the thing is that it didn't matter if I go from full screen to windowed or windowed to full screen, both helped as long as I went from one to another.

It doesn't try to cap framrate for me but it kind of feels like some physics gets weird. Like something is forcing me driving with low physics calculation rate until I do something with my client to make it normal. And the thing is that I can be very fine on some servers even when they're full etc., but for example Bens server I get the issue almost everytime I play there. Tbh I don't remember now any other server where I can get this issue this much. Usually when there are issues on other servers the game is so laggy that nobody has fun anymore at that point and that's a totally different thing.
Official Wreckfest Discord
Unofficial  WreckFest Discord!

i7 2600K @ 4,6GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

sam223

  • *
  • Posts: 3283
Yea if its server related cpu desync or upload limit reached on server everyone will feel it,not just you. Did you try swapping modes in bens server (alt+enter)
Dell U2515H 25",  i5-4690k @4.0ghz, 16gb ram, MSI GTX 1060 6GB, 120/500gb SSD, 1tb HHD, win 7, G25/Logitech pad

Online Bangers:Wreckfest - https://goo.gl/AjDHU2

St. Jimmy

  • *
  • *
  • Posts: 1523
Yea if its server related cpu desync or upload limit reached on server everyone will feel it,not just you. Did you try swapping modes in bens server (alt+enter)
Yep the alt+enter mode changing usually helped. It just didn't matter if I was full screen or full screen windowed at first, going either way helped usually.
Official Wreckfest Discord
Unofficial  WreckFest Discord!

i7 2600K @ 4,6GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

sam223

  • *
  • Posts: 3283
Yea if its server related cpu desync or upload limit reached on server everyone will feel it,not just you. Did you try swapping modes in bens server (alt+enter)
Yep the alt+enter mode changing usually helped. It just didn't matter if I was full screen or full screen windowed at first, going either way helped usually.
Really weird. It is something i have encountered myself and the alt+enter switching did always fix it. Previously i did used to receive lots of complaints from players running v-sync about server performance after server switched tracks. And always told them to turn it off. But game does run better capped at 60fps imo, and switching mode seems to fix being capped at 30fps.
Dell U2515H 25",  i5-4690k @4.0ghz, 16gb ram, MSI GTX 1060 6GB, 120/500gb SSD, 1tb HHD, win 7, G25/Logitech pad

Online Bangers:Wreckfest - https://goo.gl/AjDHU2