Author Topic: Losing moderators/admin rights each server restart  (Read 267 times)

Haloman666

  • Posts: 8
Hi everyone,

I host 3 servers on a dedicated server. Everything working great.
I just have one issue : Everytime I restart a server, moderators and admin lose their rights.

In configs files, i specified this :
clear_users=0
owner_disabled=1

Each server have their own folder, cfg and .bat :



Do you have an idea on how to fix this issue ?

Thank a lot !

Haloman666

sam223

  • *
  • Posts: 3193
The entire admin/moderator list is cached in a single file called dedicated.dset. The location of this file depends on windows version.
Doesnt matter how your .cfg files are setup etc,its all stored in that one file.

This why you will often have problems running a vanilla server and a modded server from 1 machine. Because the 2nd/3rd server you launch will load from the .dset file using the first servers settings. Multiple relaunches will eventually overwrite the settings,but then if you reset the first server,it would have the 2nd servers settings and so on.

To fix you problem:
Start one server,wait for it to load and put "clearusers" (without"") in console. This will remove all admins/mods from all servers. Then get your mods/admins to join and give them permissions again.

There is a limit to the amount of users who can have permissions,every server running from your machine will have the same mods/admins and after some time you cannot add more without clearing all.
« Last Edit: June 13, 2018, 04:10:49 PM by sam223 »
Dell U2515H 25",  i5-4690k @4.0ghz, 8gb ram, MSI GTX 1060 6GB, 120gb SSD, 1tb HHD, win 7, G25/Ps3 pad
Online Bangers:Wreckfest - https://goo.gl/AjDHU2

Haloman666

  • Posts: 8
Thank you for your fast reply.
I noticed about the file named "dedicated.dset". When I open it, it's encrypted.
I can see the name of the first server inside, but not the 2 others one.

I'm on Windows Server 2016 X64.

I have a question about your fix. Do I need to add the admin/op only on the first server (then it will be replicated to others servers), then start the 2 others, or I need to add admin/op on the 3 servers ?

Thank you very much

Haloman666

sam223

  • *
  • Posts: 3193
Thank you for your fast reply.
I noticed about the file named "dedicated.dset". When I open it, it's encrypted.
I can see the name of the first server inside, but not the 2 others one.

I'm on Windows Server 2016 X64.

I have a question about your fix. Do I need to add the admin/op only on the first server (then it will be replicated to others servers), then start the 2 others, or I need to add admin/op on the 3 servers ?

Thank you very much

Haloman666

You can open the file with bagedit,just like almost any file in the wreckfest install dir. But unfortunately there is no useful data within for permissions. Its just a list,with no readable data.
Adding it on one server should give the same users the same permission on all your servers.
Dell U2515H 25",  i5-4690k @4.0ghz, 8gb ram, MSI GTX 1060 6GB, 120gb SSD, 1tb HHD, win 7, G25/Ps3 pad
Online Bangers:Wreckfest - https://goo.gl/AjDHU2

Haloman666

  • Posts: 8
Hi,

Your fix is working.

Thank you very much !



Haloman666,