Author Topic: insta crash when open settings menu  (Read 580 times)

caramuxo

  • Posts: 1
i cant open the settings menu. if i try the game crah instantily. can you help me?
i can play all modes

LukeNoHands

  • Posts: 1
this might be your problem:

KNOWN ISSUES
Entering Settings menu results in the game crashing if more than four input devices are connected (keyboard and mouse counts as one).

Nylan

  • Posts: 3
Same issue here :(

tl1000s1997

  • Posts: 3
Same here..  >:( >:( >:(

Did removed the settings...did not help at all..
Removed most of the USB devices....no result..
Did removed the game and some left behind maps ....did not help either..
Did not touched the cloud..

After reinstalling I lost my levels (played 19.5 hours) and settings like keys and NO music ingame..back to default..
and I still cant enter the settings...

Support! People are in need of some help here...please?
« Last Edit: July 19, 2018, 12:25:35 AM by tl1000s1997 »
Windows 10 Pro
LG 29i Wide Screen + IIyama 24i ProLite screen
16GB DDR3
AMD FX-8350
AsRock 970 Extreme3 R2.0
Inno3D GTX1060 6GB
SB Audio Extreme
750w PSU
4 x HDD
2 x SSD
Nostromo N52
MS Keyboard
Roccat Kave 5.1 headset
Logitech Mouse

tl1000s1997

  • Posts: 3
Found the solution for my settings crashing..

I had installed some mods and disabled them after having issues..but the setting menu wasnt accessable anymore..

When you have mods inside the mod section of the game go to steam and got to the workshop of this game.
 Disable all favorites you've selected..and stop following them...

startup the game and in my case the settings were there again..
Windows 10 Pro
LG 29i Wide Screen + IIyama 24i ProLite screen
16GB DDR3
AMD FX-8350
AsRock 970 Extreme3 R2.0
Inno3D GTX1060 6GB
SB Audio Extreme
750w PSU
4 x HDD
2 x SSD
Nostromo N52
MS Keyboard
Roccat Kave 5.1 headset
Logitech Mouse

redarmy

  • Posts: 10
Found the solution for my settings crashing..

I had installed some mods and disabled them after having issues..but the setting menu wasnt accessable anymore..

When you have mods inside the mod section of the game go to steam and got to the workshop of this game.
 Disable all favorites you've selected..and stop following them...

startup the game and in my case the settings were there again..

happy you found a fix...but this isnt gona work for everyone. I only bought the game and loaded it up FIRST time,no mods at all...and i have the crash when selecting settings.This is so strange,the "fixes" people post such as this,and the mythical "4 USB connected so it will crash,remove some" fixes...the DEVS need to sort this out rite now,this is unacceptable. I paid real money and i want to play,now....iv been waiting a week already

tl1000s1997

  • Posts: 3
Agree, thats why i was saying it was in my case..

The situation youre in sucks, you pay good money for it and it doesnt work properly..
Hope you will find or get (update?) a solution for the problem mate...take care..
Windows 10 Pro
LG 29i Wide Screen + IIyama 24i ProLite screen
16GB DDR3
AMD FX-8350
AsRock 970 Extreme3 R2.0
Inno3D GTX1060 6GB
SB Audio Extreme
750w PSU
4 x HDD
2 x SSD
Nostromo N52
MS Keyboard
Roccat Kave 5.1 headset
Logitech Mouse

Purple44

  • *
  • Posts: 8426
This guy went through a lot get this bug fixed:   :o

https://steamcommunity.com/app/228380/discussions/0/1710690018664517186/?tscn=1532397575

Quote from: =TKZ=Pantload;1761356057401842319
Ok after reading forums I tried verious solutions and what worked just now for me was 1st update video card drivers: I had done a purg of all my drives to get rid of bloat that comes with programs and Windows. After reinstalling Win10 I forgot to install Gforce Experience and therefore my drivers were 10 months old. After loading Gforce experience and clicking ``Update Drivers``and  "Express download" (they do not load bloat) restarted. Then unpluged all USB Peripherals except K&M (ie. external HD, Flash sticks, game pad, controllers, etc) restarted again. Then started game clicked setting wella works!! Then plugged in steering wheel (USB) and restarded game clicked on setting and Wheel was detected and I was able to set it up and play with no issues other than I sucked at driving. LOL . I hope this helps. 

i7-2600K CPU " 3.5GHz
16G Ram
64 bit operating system
GTX1070
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

Purple44

  • *
  • Posts: 8426
Crash when clicking on settings.

Quote from: Vipersauce1;1742216642528708953
I hade the same problem, after resetting the Career i havent had any issues.

Quote from: Meatlumps;1742216747649041641
I had this happen when I had my PS4 controller connected to my PC. I fixed it by using Big Picture mode and setting up my PS4 controller through that. Dunno if this helps anyone else, but that's what worked for me.

Quote from: LaZyy;1742216747651830783
Hey Guys! I had the same problem. I dont know what issue it was but i tried installing windows update, verify cache, updating my graphiccard drivers and drag out the headset cable so i just had keyboard and mouse. I dont know if this worked but i typed in -setup in launch options. When starting game you can can choose do lower graphics. Put all grapichs to high and then start game. And then if you can open setting lower everything. Now my game dosent crash anymore :D
« Last Edit: August 06, 2018, 03:41:47 PM by Purple44 »
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

Purple44

  • *
  • Posts: 8426
Here another post about settings crashing Wreckfest:

ISSUE
Crash everytime when going into settings menu
DESCRIPTION
Hi, i m running an updated windows 10 x64 with i7 6700K, 16Gb of ram and a 1070 (if ever it helps).
I've allready deleted all the settings everywhere on my computer and redownload the game but it changes nothing. I m playing since the first moments of the early access (congrats for this game BTW so fun) i saw that some folders changed.
I m allways crashing when i click on settings ingame (x32 or x64 launcher aswell) and i know why. The unfortunate thing is that it wasn't crashing before the full release two or three month ago. I m playing with a G27 with a homemade handbrake. The handbrake is what it makes it crash, even if i only connect this peripheral, it s crashing even with different usb port, and ofc i tried to reinstall this peripheral on different usb port to check before report.

The controler of my analog handbrake is an arduino promicro with an analog sketch loaded to it. It's seen by windows as a classic game controler called "sparkfunmicro". The sketch is available here : https://github.com/AM-STUDIO/Analog-E-Brake
(it s working fine on every other game like assetto corsa, dirt rally, etc.)

Thx alot for all the work done, my friends and I can t wait to be back on it !! (handbrake is strongly needed in order to avoid damages on my radiator when landing into someone ^^)

EDIT: no mod
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

Purple44

  • *
  • Posts: 8426
Here a work around to get to your settings:

Crash when clicking on settings.

Quote from: Vektor T;1745594817442370794
Hey, guys, just to share with you all. Nothing I tried fixed the issue, but while I can't go to settings from the main menu I can from the race. I just started a random event, hit ESC, settings and voilà. Not ideal but works for me and maybe for some of you guys too.


Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel