Author Topic: Help needed with creating a custom animated object.  (Read 94 times)

MarcellusW

  • Posts: 105
I my attempt to create a custom animated object ( a road barricade lamp ), I have run into a wall.

The objects has 3 sub-objects, the lamp casing with transparency on the spots I want the light to shine through, a light source
and a cube open on 2 sides rotating on the Z axis (to obscure the light 2x per rotation to simulate a blinking effect)

I used the "start_dynamic_animations.dntp" and the files that go with it I found in Purple44's cops n robbers mod (for the wedgespinner),
but with these the game crashed on loading the track the object is in.

I do not know how the Dev's made their animated objects, but I did find that the "spinner" objects in the cops n robbers mod also have "shapes" in the .scne file ( 2 boxes (dummie objects?)), which my object lacks.

I'm not sure if this is even possible, that the light source is not bleeding through the material ( I used a "point" lamp for this object )
or that I should use a spotlight instead to create a lighthouse/police light/blinking effect. (or even have 2 spotlights in opposite direction and have them rotate on the Z axis )

Any help would be highly appreciated.

 

MarcellusW

  • Posts: 105
I've been digging a little deeper in to this and with the help from the spinner objects ( made by Mazay and The Very End ) from the cops n robbers mod,
I learned that "objectname#col1" ( which is a copy of the actual object without a material ) is responsible for the "shape" in the scne file. ( a BIG thanks to Purple44 for the Blender files )

I made the object and animation in Blender, ported to 3ds max, because unfortunately animation data is not exported to BGO from Blender, and finalized in max.
All animation data shows up in BagEdit, aswell as the "shape", I used the same dntp, fxtr and agan files the spinners use, but in-game the animation does not show.
However, the animation data seems to be working, I copied the "shape" data from the spinner object into my scne file and that gave the effect the spinner object, yet my object remained static.
Apparently I'm overlooking something. (because the spinners blender files have no animation data, I cannot tell what I'm overlooking)
Also found out that copying the animation data from the spinner into my scne file makes the game crash.

Edit:
Got the animation show in-game, it seems that both "object" and "object#col1"  need the animation data to work.
I now need to find the proper settings in material to see if the intended effect (obscuring the light source in 1 sec interfals to simulate a blinking effect) is actually working.
(current settings and weather map on test track do not indicate that it is )