Author Topic: Fatal Error at launch  (Read 185 times)

Conte Zero

  • *
  • Posts: 502
Had to reinstall game from Steam, it always worked flawlessly, but today I can't play it, got this message, tried everything, please help.
Local files integrity test on Steam says "1 file missing, it will be obtained again", but nothing happens. Here are screens of the error message.
Please help, thank you.



Saippuakivikauppias

St. Jimmy

  • *
  • *
  • Posts: 1516
Could be that the .vsrp file is saying to un/install non-existing file. At least it looks like that in the files. It says to uninstall that file even though it doesn't exist.
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

Purple44

  • *
  • Posts: 8350
I took a look at the /06_american car folder and there no spoiler_rear_0.vhcl files. There:

spoiler_rear_c_0.vhcl
spoiler_rear_l_0.vhcl
spoiler_rear_r_0.vhcl


Zero, you remember buying or swapping spoiler for the RoadSlayer GT? Did you just recently unlock the RoadSlayer GT doing career mode?

Might try this for a test, go here: c:\Program Files\Steam\userdata\[User ID]\228380\local\wreckfest

and rename this file: playerinventory2.usli  to playerinventory2-test.usli


See if error go away. If this works, you going have upgrade you cars again and may have to re-buy parts. Could use the Free Market mod to re-buy parts if needed, then disable mod.

Here thread with same issue, but no fix found: http://community.bugbeargames.com/index.php/topic,11503.0.html


Is there a problem with unlocking the RoadSlayer GT or is there a problem with one the spoiler parts?

I unlock the GT version last week and use it online Saturday, no problem. I did check the visual parts when I got the car, did not change the spoiler RoadSlayer GT came with.
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

Conte Zero

  • *
  • Posts: 502
Thank you Purple and Jimmy
will give it a try. Only thing I can't understand is how a freshly installed game can create this problem. Duh.

@Purple I can'r remember anything about the last period I used Wreckfest; no purchases nor customizations. I don't even remeber the cars in my garage, sorry.

But I just tried to follow your tutorial, and tere's no .usli file on my PC. Nothing.
I am stuck, again. I can try to uninstall game and re-download it for the third time, but I don't know what will change.
« Last Edit: September 19, 2018, 09:36:10 AM by Conte Zero »
Saippuakivikauppias

Purple44

  • *
  • Posts: 8350
You did find your \228380\local\wreckfest folder on the hard drive where Steam is installed?

This where you will find the career, cars5 and playerinventory2 files.

Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

Conte Zero

  • *
  • Posts: 502
re-downloaded, again.
Windows search can't find any of those names, Purple: no cars5, no playerinventory, so I can't locate the correct folder.
What the hell is going on?
Game still dead, about to give up and pass on something that works.. I'm fed up.
Saippuakivikauppias

St. Jimmy

  • *
  • *
  • Posts: 1516
Don't try to use Windows search, just go in the location straight as was guided.
Save files are in C:\Program Files (x86)\Steam\userdata\<insert_your_id>\228380\local\wreckfest
Of course if you've actually installed Steam on other drive/place it's there. Steam location isn't necessary the same as where the game is located if you use different install folders for games.
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

Conte Zero

  • *
  • Posts: 502
Don't try to use Windows search, just go in the location straight as was guided.
Save files are in C:\Program Files (x86)\Steam\userdata\<insert_your_id>\228380\local\wreckfest
Of course if you've actually installed Steam on other drive/place it's there. Steam location isn't necessary the same as where the game is located if you use different install folders for games.
Found it, and I also tried Purple's suggestione about playerinventory, but no good, still crashing at launch...


Saippuakivikauppias

Purple44

  • *
  • Posts: 8350
Then that mean it either the car5 file or career file that has gone bad, I'm thinking.

So try renaming car5.ccrs file to cars-test.ccrs and see if error goes away. If that don't work, rename career.cres to career-test.cres.

If it turn out to be career gone bad, you maybe can keep the old cars5 and playerinventory2 files.
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

Conte Zero

  • *
  • Posts: 502
Then that mean it either the car5 file or career file that has gone bad, I'm thinking.

So try renaming car5.ccrs file to cars-test.ccrs and see if error goes away. If that don't work, rename career.cres to career-test.cres.

If it turn out to be career gone bad, you maybe can keep the old cars5 and playerinventory2 files.
Purple, it worked!
Yesterday I just ripped cars5 off the folder and brutally started the game: everything smooth and working. I suppose the game re-created that file immediately from scratch, but it worked!

I've only lost one of my two cars, but who cares, I had a mod/cheat that granted me U$ 8.500.000 on my bank account, so I can buy cars, parts, circuits, I probably can buy Bugbear itself ahahahaha


Thank you all, that thing was getting very frustrating
Saippuakivikauppias