Author Topic: Can't Select NVIDIA Card on NCG Tech Demo  (Read 5553 times)

dbs213

  • *
  • Posts: 1566
I can't seem to select my NVIDIA card on the video options before running the game forcing me to use the Intel HD card (which doesn't like HD games contrary to the name). My card is an NVIDIA Geforce GTX 660M.

Any way to get it recognized?
My Specs: Intel Core i7-4790 3.60GHz | 8GB Ram| Nvidia GeForce GTX 1060 6GB | Windows 7 Home Premium 64bit | 1TB Hard Drive
======================================
"Straight roads are for fast cars, turns are for fast drivers." - Colin McRae (1968 - 2007)

chorst13

  • Posts: 6
same problem here.

dbs213

  • *
  • Posts: 1566
Someone told me this solution and it worked. I'm pumping out somewhere in between 30 to 60 fps with full graphics settings and 7 AI players

Great demo Bugbear! That was really fun. Although it felt a bit too slippy, like always drifting. I liked the grip of FO2 cars more.

Performance is good on my laptop (i5 / gt 555m), unless my car is really sandwiched - drops below 10fps in that case until I reset damage. Not sure if it's my audio driver or the game, but sound worked only on the first launch so far?

Quote
The video settings don't detect my NVIDIA GTX 660M card and only shows an Intel HD card option. Any workarounds?
On notebooks with Nvidia Optimus, it should be as easy right-click on desktop, Nvidia Control Panel



Add NCG sneak peak to the program list and set it to high-performance gpu



Apply and have fun :)
My Specs: Intel Core i7-4790 3.60GHz | 8GB Ram| Nvidia GeForce GTX 1060 6GB | Windows 7 Home Premium 64bit | 1TB Hard Drive
======================================
"Straight roads are for fast cars, turns are for fast drivers." - Colin McRae (1968 - 2007)

chorst13

  • Posts: 6
I have tried to use the workaround mentioned above, but I don't get any increased performance.  Also, the launcher still only recognizes the intel graphics.  I have a gtx 765m and it should be able to handle all of the ai and crash physics.  I hope that BugBear can fix this problem before the final release.


chorst13

  • Posts: 6
I have done some more research, and apparently, most old game launchers don't recognize discrete gpus if the laptop is using optimus technology.  However, using the nvidia control panel forcing the use of the gpu supposedly works. 


I downloaded a tool from here to see if the nvidia gpu was active during the game and apparently it was. 
http://forums.laptopvideo2go.com/topic/26992-optimus-test-tools-finally-in-users-hands/

I am getting decent performance, however i expected better from my gpu.  It gets pretty choppy after about 15 seconds of running with the ai on.  I hope that there will be more extensive settings to control particles/ debris to try and increase performance even more.

Purple44

  • *
  • Posts: 8114
I have done some more research, and apparently, most old game launchers don't recognize discrete gpus if the laptop is using optimus technology.  However, using the nvidia control panel forcing the use of the gpu supposedly works. 


I downloaded a tool from here to see if the nvidia gpu was active during the game and apparently it was. 
http://forums.laptopvideo2go.com/topic/26992-optimus-test-tools-finally-in-users-hands/

I am getting decent performance, however i expected better from my gpu.  It gets pretty choppy after about 15 seconds of running with the ai on.  I hope that there will be more extensive settings to control particles/ debris to try and increase performance even more.

Ya, when final version ( maybe even alpha/ beta ) get release, need some advance graphic options. Especially for particle effects ( dust, smoke ). In GRID 1, I could not max out particle effects setting until I upgraded 8800 to a 4870.
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel