Author Topic: Can't read discrete ATI video card(laptop)  (Read 3943 times)

Sorcesman

  • Posts: 6
Hi everyone! Need help, found a similar theme, but it was on NVIDIA chips.

The problem is that I have two video cards on a laptop, integrated and discrete, so here is a discrete card is not recognized, enclose screen.
I set up Control Center exhibited priority card application identified enhanced performance, nothing happened. Who faced, please help to understand. Simply impossible to play on an integrated graphics card :(








Thanks!
« Last Edit: March 04, 2014, 12:49:37 AM by Sorcesman »

Tapio Vierros

  • Posts: 518
When high-performance profile is selected for NCG, it should work regardless what it says in the Rendering device selector. Did you try actually starting the game?

Sorcesman

  • Posts: 6
When high-performance profile is selected for NCG, it should work regardless what it says in the Rendering device selector. Did you try actually starting the game?

Yes, I started game - terrible lags, as step-by-step strategy, a lot of things didn't appear, moreover, were felt on behavior of system (cooler speed for example) that game goes on the integrated card. At start of other games (Battlefiled 4) - everything works perfectly, according to priorities.

I tried to switch-off the integrated card in a device manager, here:


well, that's what i got

Blapple

  • Posts: 3
I'm having the same problem as the topic starter.

My Laptop got a Intel HD4000 and a ATI 7670m, Os is Win 8.1(64bit) - with latest drivers.
I5-3337u , 8gb ram.

When I try to switch of my hd4000 card my display goes of and stays off until I re-activate it in windows safe mode.
Never the less I can't switch between gfx cards in the Gameoptions ( get to choose between intel hd & intel hd) neither it works with ATI Catalyst options.
I tried to max out the gfx options to force the laptop to switch to the ati card, didn't work too.

I would really enjoy to play the game with more then 15 fps :D, maybe you know something I can try.

Tapio Vierros

  • Posts: 518
Usually these problem goes away by setting high-performance profile in the GPU control panel and ignoring what it says in the NCG render device combo box. Have you tried setting some kind of global performance mode on in Catalyst CC instead of just an app profile for NCG?

Blapple

  • Posts: 3
Yes that pushed the performance!
The global thing worked out, I guess.

Now I'm able to play at 720p with every other option at mid (AA off).
->Derby stadium, 24 cars -> between 20-30 fps.

Not the best performance, but hey, it's pre-aplhpa :). At least I can play it now, thanks.  :D

Sorcesman

  • Posts: 6
Yes that pushed the performance!
The global thing worked out, I guess.

Now I'm able to play at 720p with every other option at mid (AA off).
->Derby stadium, 24 cars -> between 20-30 fps.

Not the best performance, but hey, it's pre-aplhpa :). At least I can play it now, thanks.  :D

Hi all again!

Maybe this will help, the problem was resolved quite unexpectedly, I set compatibility options when running the game on windows 7.
Strange of course, but it worked.

Purple44

  • *
  • Posts: 8359
Yes that pushed the performance!
The global thing worked out, I guess.

Now I'm able to play at 720p with every other option at mid (AA off).
->Derby stadium, 24 cars -> between 20-30 fps.

Not the best performance, but hey, it's pre-aplhpa :). At least I can play it now, thanks.  :D

Hi all again!

Maybe this will help, the problem was resolved quite unexpectedly, I set compatibility options when running the game on windows 7.
Strange of course, but it worked.

Hi, could you explain this more? You running Win7 and set compatibility option to a different version of Windows?
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

Sorcesman

  • Posts: 6
Yes that pushed the performance!
The global thing worked out, I guess.

Now I'm able to play at 720p with every other option at mid (AA off).
->Derby stadium, 24 cars -> between 20-30 fps.

Not the best performance, but hey, it's pre-aplhpa :). At least I can play it now, thanks.  :D

Hi all again!

Maybe this will help, the problem was resolved quite unexpectedly, I set compatibility options when running the game on windows 7.
Strange of course, but it worked.

Hi, could you explain this more? You running Win7 and set compatibility option to a different version of Windows?

Hi! Sure, I have windows 8.1, but I ran the game in compatibility mode for windows 7, and it worked, FPS rose to normal values, missing lags. Well...may it will help for others!

Purple44

  • *
  • Posts: 8359
Yes that pushed the performance!
The global thing worked out, I guess.

Now I'm able to play at 720p with every other option at mid (AA off).
->Derby stadium, 24 cars -> between 20-30 fps.

Not the best performance, but hey, it's pre-aplhpa :). At least I can play it now, thanks.  :D

Hi all again!

Maybe this will help, the problem was resolved quite unexpectedly, I set compatibility options when running the game on windows 7.
Strange of course, but it worked.

Hi, could you explain this more? You running Win7 and set compatibility option to a different version of Windows?

Hi! Sure, I have windows 8.1, but I ran the game in compatibility mode for windows 7, and it worked, FPS rose to normal values, missing lags. Well...may it will help for others!

Thanks for clearing that up. Will put tip in solution thread. :)
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

Blapple

  • Posts: 3
Yes the windows 7 compatibility mode helped for me, too.

So all in all, with the Global settings in CCC & the compatibility mode for win 7 rose the fps to a playable level :) . - With everything on mid settings @ 720p. But without AA.


But the graphics card is still not using 100% of it's power, it takes about 10 min+ untill the fan is nearly at maximum. In bf3 for example it's getting alot faster hot.


anyway thank's alot for the support!