Author Topic: How To Setup A Dedicated Server or Servers  (Read 38148 times)

Facial_Burns

  • *
  • *
  • *
  • Posts: 435
In the console type tracks and it will list all the names including the name for the mod tracks
My steam group where u can always find some friends on NCG
http://steamcommunity.com/groups/WRCserver
My NCG discord server
https://discord.gg/010U99akJwUY82yjk

Basic pc specs:
16gb ram
Amd athlon FX 8350 8 core
nividia gtx 970
gigabte motherboard
3tb hdd
windows 8.1 pro

St. Jimmy

  • *
  • *
  • Posts: 1466
For some reason I can't get server to launch with mods. Anyone know why? Even trying the example mod didn't work..

# Mod folder names in a comma separated list
mods=example


Isn't that right?
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

Purple44

  • *
  • Posts: 8114
For some reason I can't get server to launch with mods. Anyone know why? Even trying the example mod didn't work..

# Mod folder names in a comma separated list
mods=example


Isn't that right?


Jimmy, give this thread a read:

Running dedicated server with Workshop mods?
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

St. Jimmy

  • *
  • *
  • Posts: 1466
Jimmy, give this thread a read:

Running dedicated server with Workshop mods?
Dam there's nothing in there to help me. Well that at least confirm I'm doing it right but it just doesn't work...
I can't even run without Workshop mods. Even using the example car fails. The server never get any mods and is always without mod, no matter what there is after "mods=" parameter.

I've tried both in manual config and with WreckFest Server Manager app without any luck :(
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

Purple44

  • *
  • Posts: 8114
Doing this, mods=688649575  did not load the correct mod?

I'm thinking you can't run a mod unless it been uploaded to the Steam Workshop.

Server software I think does not know to look at the \mods folder.
« Last Edit: August 29, 2016, 04:24:53 PM by Purple44 »
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

St. Jimmy

  • *
  • *
  • Posts: 1466
Doing this, mods=688649575  did not load the correct mod?

I'm thinking you can't run a mod unless it been uploaded to the Steam Workshop.

Server software I think does not know to look at the \mods folder.
Oh it's that way? I thought it was other way around.

But still it doesn't launch with a mod when doing that... No mods loaded at all because I can only get in to the server without any mods.


// Oh hmmm now I got it. There was something likely conflicting with this guide I made http://community.bugbeargames.com/index.php/topic,7798.msg85010.html#msg85010 I guess it's the server 2 folder or something. Need to investigate it later.

///Too bad WreckFest Server Manager doesn't like launch mods :(
« Last Edit: August 29, 2016, 05:00:33 PM by St. Jimmy »
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

CFodder

  • Posts: 215
Have added in the latest tracks, unsure what the 'proper' names for forest7 and forest7b are though.

Janne Suur-Näkki

  • *
  • *
  • Posts: 1991
Forest7 = Mixed 3, Route 2 and forest7b = Mixed 3, Route 2 Reverse.

CFodder

  • Posts: 215
Thanks Janne :)

Janne Suur-Näkki

  • *
  • *
  • Posts: 1991
Sorry! Not sure what I was thinking this morning, but of course forest7 = Mixed 3 Route 1 and forest 7b = Mixed 3 Route 2. The reverse routes are the same but with _rev tag at the end.

Purple44

  • *
  • Posts: 8114
I would like get the IP address of my dedicated server. Is there a way of finding it out?

I tried the" ? "command, it show ports but not the IP address of server.
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

St. Jimmy

  • *
  • *
  • Posts: 1466
I would like get the IP address of my dedicated server. Is there a way of finding it out?

I tried the" ? "command, it show ports but not the IP address of server.
You need/want to get it from the dedi console or are you ok getting it any other way? If you've access to the dedi server PC, you can just go in browser and go in a webpage like "what's my IP" that tells it or you can open cmd and write /ipconfig. Not sure did Wreckfest Server finder also tell the IP address. Not sure does the dedi program also take that  /ipconfig command.
Unofficial  WreckFest Discord!

i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

Purple44

  • *
  • Posts: 8114
The /ipconfig command did not work, Google say I need to drop the " / ". Typing ipconfig work in cmd window, but not the dedicated server window. But this command only give me my internal IP address behind the router. I wanted my public IP address so a guy could PING me.

Thanks to Google I found this site that give me my public IP address:   http://ip4.me/
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

CFodder

  • Posts: 215
Added in new tracks and damage modifier setting for track rotations.