Author Topic: Forum badges  (Read 29744 times)

dave_mx85

  • Posts: 26
hummm mine won't show up


Did you buy Wreckfest and\or Stuntfest form Bugbear web site? http://www.wreckfestgame.com/wreckfest/

If so, did you get email from from SendQwl with link to your Steam Keys and forum badge?



If got forum badge key, did you go here to register?  http://community.bugbeargames.com/index.php?action=addcdkey

Nope i bought from steam, thats why

St. Jimmy

  • *
  • *
  • Posts: 1382
Nope i bought from steam, thats why
Yep Steam purchases don't have any badges available. You get it only if you order straight from BB.
Join WreckFest Discord!

Contribute to the WreckFest wiki!


i7 2600K @ 4,7GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

RiptoR

  • *
  • Posts: 1
So how do we activate our badges? I've registered my key, but nothing is showing up.

*edit* Nevermind, it seems it only shows up when you post something, and not on your forum profile.

Purple44

  • *
  • Posts: 7856
So how do we activate our badges? I've registered my key, but nothing is showing up.

*edit* Nevermind, it seems it only shows up when you post something, and not on your forum profile.

Hi, welcome to the forum.

I see you have a Teammember badge.  :D  Since you can't buy from Bugbear web page any more, only from Steam now, I take it you bought Wreckfest awhile ago and just now registering at the forum?
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel