Author Topic: Forum badges  (Read 36984 times)

dave_mx85

  • Posts: 26
hummm mine won't show up

Did you buy Wreckfest and\or Stuntfest form Bugbear web site? http://www.wreckfestgame.com/wreckfest/

If so, did you get email from from SendQwl with link to your Steam Keys and forum badge?



If got forum badge key, did you go here to register?  http://community.bugbeargames.com/index.php?action=addcdkey
Nope i bought from steam, thats why

St. Jimmy

  • *
  • *
  • Posts: 1517
Nope i bought from steam, thats why
Yep Steam purchases don't have any badges available. You get it only if you order straight from BB.
Official Wreckfest Discord
Unofficial  WreckFest Discord!

i7 2600K @ 4,6GHz
GTX 1070 8GB
16GB CL9 2133 MHz
750W PSU
Win7 Ultimate 64-bit
Fanatec CSR

RiptoR

  • *
  • Posts: 3
So how do we activate our badges? I've registered my key, but nothing is showing up.

*edit* Nevermind, it seems it only shows up when you post something, and not on your forum profile.

Purple44

  • *
  • Posts: 8351
So how do we activate our badges? I've registered my key, but nothing is showing up.

*edit* Nevermind, it seems it only shows up when you post something, and not on your forum profile.

Hi, welcome to the forum.

I see you have a Teammember badge.  :D  Since you can't buy from Bugbear web page any more, only from Steam now, I take it you bought Wreckfest awhile ago and just now registering at the forum?
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

DigitalNikki

  • *
  • Posts: 2
It would be nice if there was a way to check for a badge without posting.

Devils Shadow here 1st time poster long time wrecker. Just trying to register my team bugbear. Is it working?

Hmmm, so i got the team bug bear key, registered it and my team bug bear badge isnt showing up. Any ideas?


The Very End

  • *
  • *
  • Posts: 2416
Remember that key for forum badge has to be registered on a other place than the name (for credits). If it still does not work I would just send a message to Bugbear, they usually fix it.

Where else does it have to be registered?

The Very End

  • *
  • *
  • Posts: 2416
Think you have to go to profile - register key for forum badge. Long time since I done this so not sure sorry.

Purple44

  • *
  • Posts: 8351
Where else does it have to be registered?

You did put your mouse marker on Profile at top of forum page and clicked, Register NCG license key? I thought you did this.
Flatout Joint, where the mods were.

i5 2500 i7 8700, 16GB, Nvidia 660 960 1060 6GB, Win 10 64bit, DFGT Wheel

The top where it says register name? Then add product key to that? I did do that

Tonza

  • *
  • Posts: 484
The top where it says register name? Then add product key to that? I did do that
Hover cursor over profile tab and click Register NCG license key..

Thank you! I am doing this mobile and couldn't hover over anything. I thought the register name was it. Thanks a bunch!