Author Topic: Help With MSI GE70 OND Dual Graphics Card  (Read 255 times)

leonjames87

  • Posts: 2
Hi guys and gals,
My name is Leon and although I'm new to this forum, I've had Next Car Game/Wreckfest for a more than a few years now and I still have an issue. My laptop won't pick up my Nvidia 960M over my onboard Intel crap graphics card and I think this is what's causing a max fps of 30 fps with all settings on low or turned off!
I've used the Nvidia video setting to attempt to force it to run on the 960M, but when loading the game initially, it still only finds the Intel...
What could I do next please?
Thankyou in advance, Leon
P.s. I'll add my PC specs when I get home as I'm on my mobile at the moment...
MSI GE70 OND, 16gb Kingston ram, 2gb Nvidia George 960M, HD Realtech Audio, 750gb 7200rpm hdd

Purple44

  • *
  • Posts: 7031
Hi, this been a know problem with laptops for years now. I hope Bugbear can get a fix for it before final release this year.

MY PRIMARY DISPLAY ADAPTER IS NOT DETECTED BY THE GAME!
Most likely you need to create a profile for the game in the display adapter settings and make sure the profile is set to use the primary display adapter. If you're using NVIDIA Optimus, create a new profile in the NVIDIA Control Panel under 3D Settings/Manage 3D Settings for the game, and make sure that 'High-Performance NVIDIA processor' is selected as the preferred graphics processor in Program Settings. For AMD users, the process is pretty much the same. Furthermore, if your laptop has an on-board switch for selecting between Stamina and Speed modes, make sure that Speed is selected; the primary displayer adapter is available only in the Speed mode.

Known solutions thread for fixes to problems running NCG and Sneak Peek.


Great demo Bugbear! That was really fun. Although it felt a bit too slippy, like always drifting. I liked the grip of FO2 cars more.

Performance is good on my laptop (i5 / gt 555m), unless my car is really sandwiched - drops below 10fps in that case until I reset damage. Not sure if it's my audio driver or the game, but sound worked only on the first launch so far?

Quote
The video settings don't detect my NVIDIA GTX 660M card and only shows an Intel HD card option. Any workarounds?

On notebooks with Nvidia Optimus, it should be as easy right-click on desktop, Nvidia Control Panel



Add NCG sneak peak to the program list and set it to high-performance gpu



Apply and have fun :)


Did you click the ADD button?

Right click on pic, select View Image to see pic full size.

« Last Edit: June 03, 2017, 05:56:28 AM by Purple44 »
Flatout Joint, where the mods were.

i5 2500, 8GB, Nvidia 660 960, SB Recon, Win 10 or Win7 64bit, DFGT Wheel

leonjames87

  • Posts: 2
Thankyou for the help Purple44, I'll try some of the options you've listed and come back with results this evening.
It's weird that my old desktop (no longer with us) had 4gb of ram, an original Intel quad core processor and a 1gb nvidia gpu (can't remember the model) could run it at higher fps than my msi gaming laptop!
Hopefully bugbear will sort it out soon because it definitely been like this since I bought the laptop over a year ago now...