Author Topic: Camera flipped when driving forward/backward  (Read 266 times)

Finsku

  • *
  • *
  • Posts: 592
ISSUE
Camera flipped when driving forward/backward

DESCRIPTION
Camera flipped when driving forward/backward. Camera acts like normal but while driving forward camera is pointing backward and while driving backward camera is pointing forward. Same happened with other camera positions (driver, 3rd person, on-hood, ...). Pressing looking buttons (look to left, right, etc) worked but after pressing looking forward it returned to watch backwards.

I took pictures for another "bug" report when this happened. I drove backwards and I opened picture mode. After returning into gameplay camera started to act like this.
I tried to start race again going to Main menu and selecting same quick race settings but the problem still occurred.
After restarting game the problem disappeared.

I tried to recreate this bug with driving backwards or pressing camera inputs (forward,backward,left,right) while going to picture mode but I couldn't recreate the bug.

I used Logitech Driving Force PRO wheel and mouse when I took the pictures and the problem appeared.

SCREENSHOT/VIDEO
Doesn't help imo, but here couple pictures:


While driving forward


While driving backward

I took pictures with ShareX so I was stupid ´because I didn't take pictures from speedometer  ::)
« Last Edit: July 04, 2017, 09:25:28 PM by Janne Suur-Näkki »

Janne Suur-Näkki

  • *
  • *
  • Posts: 1746
I think I've personally seen this bug occur just one time, so it's definitely an odd one. If anyone manages to get a repro for this we'd love to hear.
INTEL i7-4790K @ 4.8GHZ || EKWB WATER COOLING || NVIDIA TITAN BLACK || GIGABYTE G1.SNIPER Z97 || NEXUS RX-8500 || 16GB CORSAIR VENGEANCE || 500GB SAMSUNG 850 EVO SSD || 4TB HDD || ASUS PROART PA279Q || ASUS PROART PA248Q || 3DCONNEXION SPACEPILOT PRO || NI KOMPLETE AUDIO 6 || WINDOWS 8.1 PRO

Finsku

  • *
  • *
  • Posts: 592
Okay.. something odd happened

I reproduced bug twice in a row while testing another but (reported here)


^ I'm not pressing any buttons (only screenshot buttons to take image)

While writing this message I tested game and I got it third time. I went to settings and I couldn't see anything odd there. After closing settings windows the camera was facing to right direction.

I don't know, but IMO looks like the camera is facing backwards when I'm starting game but in couple frames (happens so fast) it turns and camera faces to where it should.

I was thinking did it come because I used multiple different controllers to select a car (another bug report).. I don't know  :-X


Finsku

  • *
  • *
  • Posts: 592
I reproduced it again. It looks more and more that the reason - why this happens - is using different controllers.

On this time when I took photos with Photo Mode, I selected the mode with gaming pad (Logitech Rumble Gamepad F510) and then used mouse to move camera and I took screenshots. I went back to game with game pad and the camera was flipped over (facing backwards).

And again, after going to settings (while race is going) and back to race the problem disappeared.

Tonza

  • *
  • Posts: 355
I reproduced it again. It looks more and more that the reason - why this happens - is using different controllers.

On this time when I took photos with Photo Mode, I selected the mode with gaming pad (Logitech Rumble Gamepad F510) and then used mouse to move camera and I took screenshots. I went back to game with game pad and the camera was flipped over (facing backwards).

And again, after going to settings (while race is going) and back to race the problem disappeared.

I switch between kb&mouse and gamepad all the time and this has never occured to me

Finsku

  • *
  • *
  • Posts: 592
I reproduced it again. It looks more and more that the reason - why this happens - is using different controllers.

On this time when I took photos with Photo Mode, I selected the mode with gaming pad (Logitech Rumble Gamepad F510) and then used mouse to move camera and I took screenshots. I went back to game with game pad and the camera was flipped over (facing backwards).

And again, after going to settings (while race is going) and back to race the problem disappeared.

I switch between kb&mouse and gamepad all the time and this has never occured to me

Strange  ??? Because I'm getting this bug every time when I use mouse on pause menu and then use gaming pad. Happened again without the Photo Mode

Gaming pad is connected to PC before launching game.

EDIT: I didn't remember to mention, but I removed all files under Steam/Userdata after update.
And gaming pad is set to XInput mode (not DirectInput mode). I can choose with switch under the gaming pad which input mode I use.
« Last Edit: December 18, 2017, 06:16:12 PM by Finsku »

Finsku

  • *
  • *
  • Posts: 592
While I was took video to show the bug I noticed the problem will come if I use software called ShareX. It is a tool to capture screen with hotkeys.

Here's the video
www.youtube.com/watch?v=VydXniDvLqM?t=1m38s