Bugbear Community

Wreckfest => Support => Topic started by: CorradoSKJ on August 18, 2015, 11:20:19 PM

Title: Game crash when i try go settings
Post by: CorradoSKJ on August 18, 2015, 11:20:19 PM
Hi,
my problem is crash when i try go to settings, i unplug my all device but still i can't go to settings.
I don't now where is log files.
I try x86 and x64 version.
Title: Re: Game crash when i try go settings
Post by: Purple44 on August 19, 2015, 07:00:40 AM
Hi,
my problem is crash when i try go to settings, i unplug my all device but still i can't go to settings.
I don't now where is log files.
I try x86 and x64 version.

Give this post a try:

THE DAMN GAME IS NOT WORKING
First of all, please verify the integrity of the game cache to make sure the game is correctly installed. Also, please remove the user data generated by the previous game versions by navigating to [STEAM INSTALLATION FOLDER]/userdata/[USER ID]/228380/local and removing the folder labeled 'wreckfest early access'. The default Steam installation folder is 'C:\Program Files (x86)\Steam'.
Title: Re: Game crash when i try go settings
Post by: CorradoSKJ on August 19, 2015, 11:56:27 PM
I forget, all this steps I make, Integrity check, delete saves, disable all my USB device and remove saves, still game crash when I try go to settings
Title: Re: Game crash when i try go settings
Post by: Purple44 on August 20, 2015, 04:08:52 AM
I forget, all this steps I make, Integrity check, delete saves, disable all my USB device and remove saves, still game crash when I try go to settings

Sound like you tried a few things.

If you skip going to menu, can you pick a car and go race?

If you unplugged the Logitech G25 Shifter with Leo Bodnar adapter, so you just have the KB plugged in, no other controllers, can you run a race? Can you go to settings and not  crash the game?

I wonder if this Leo Bodnar adapter is causing problems?

Won't recognize Logitech pedals.
(http://community.bugbeargames.com/index.php/topic,6464.0.html)
Title: Re: Game crash when i try go settings
Post by: CorradoSKJ on August 20, 2015, 10:01:03 PM
I unplug my all device and still i have this problem and yes, i can run the race when i plug my Logitech F310 Gamepad, game automatically recognize this pad and assign buttons
Title: Re: Game crash when i try go settings
Post by: supersmo on May 30, 2017, 10:29:54 AM
(I know I'm reviving an old topic but the issue is identical.)

I can start the game and race and everything looks fine, but as soon as I go to Menu -> Settings the game crashes with a standard Windows popup: "Wreckfest_x64.exe has stopped working".

No logs can be found except for the windows event log.
(I've searched for "Report.*" which was mentioned in another thread but couldn't find the file.)

What I have tried so far:
* Updated to latest graphics drivers.
* Tested with and without the G29 racing wheel.
* Deleted ...\Steam\userdata\...\...\local\wreckfest early access
* Verified integrity of game files via Steam.
* Tried different resolutions and graphics settings by first deleting settings.conf in folder mentioned above and changing the settings in the popup before the game starts.
* 32 bit version, 64 bit version.

I don't have this issue in any other game.

Error in event log: (Translated to English)
Error occured in the program by name:: Wreckfest_x64.exe, version 0.0.0.0, timestamp 0x58b00c59
, the error occured in the module by name: ntdll.dll, version 10.0.14393.479, timestamp 0x5825887f
Errorcode: 0xc00000fd
Felförskjutning: 0x0000000000040e57
Process-ID: 0x3b98
Program start time: 0x01d2d90fa035add6
Path to application: D:\Spel\Steam\steamapps\common\Bugbear Entertainment\Wreckfest_x64.exe
Path to module: C:\WINDOWS\SYSTEM32\ntdll.dll
Report-ID: 2287a21d-2026-48fc-a9bf-30aa82b50fb7
Full name of the faulting package:
Program-ID relative to the relative to the faulting package:

Thankful for assistance.
Title: Re: Game crash when i try go settings
Post by: St. Jimmy on May 30, 2017, 12:53:01 PM
Have you done the graphic drivers update so you first uninstall the current one (with a program like DiplayDriverUninstaller) and then install the new ones so it's a clean install?

Google "ntdll.dll crash" there are likely some tips. Likely something wrong with display drivers or corrupted d3dx file(s).

Or it's maybe about mouse/keyboard, audio drivers or something like that?
Title: Re: Game crash when i try go settings
Post by: Purple44 on May 30, 2017, 12:58:44 PM
If use Esc key to bring up a menu and then click settings, does that crash your game?

When first start Wreckfest, can you go to the settings menu? Is it only after you done first race or derby, settings menu crashes your game?
Title: Re: Game crash when i try go settings
Post by: supersmo on May 30, 2017, 02:02:33 PM
I've now tried the DisplayDriverUninstaller. (didn't know it existed before)
When the driver was gone I managed to start the game with the "Windows basic Display Driver". It ran at 1 FPS but crashed in the exact same way when accessing the settings menu.

If use Esc key to bring up a menu and then click settings, does that crash your game?

When first start Wreckfest, can you go to the settings menu? Is it only after you done first race or derby, settings menu crashes your game?
Yes. It crashes in any way I try to access the in-game settings.
* Start Game -> Menu -> Settings
* Start Game -> Start a race -> Esc -> Settings.

I am able to set Display settings if I delete the settings.conf file and then start the game. Then there is a popup with screen settings before the game launches.
Title: Re: Game crash when i try go settings
Post by: Purple44 on May 30, 2017, 07:45:20 PM
If right click Wreckfest in Steam library and click properties and then click set launch options and add -setup. This will bring up the graphic settings window before came starts.

(http://www.lay-zmattress.com/flatout2/purple44/Next%20Car%20Game%202016/setup-graphics-window.jpg)

Don't know what else to try. Maybe the new big update that coming soon might fix your problem.
Title: Re: Game crash when i try go settings
Post by: supersmo on May 30, 2017, 08:29:27 PM
It's FIXED!
There was a windows update that I had to trigger manually called "Windows Creators Update".
I installed it and ntdll.dll got updated, this in turn fixed the issue!

@Purple44 & St. Jimmy
Thank you for helping out. :-)