Flatout 2 on Mac - LAN play sees the other game but game session no longer avail

FlatOut2OnMac

New Member
I have 2 Macs, no firewall, they can see each other on the LAN and both of them have Flatout 2 installed (got it from the App Store last week).

On the first Mac, I create a LAN game (just single default race) - all seems fine, the "Start Race" is disabled, which I assume stays disabled until another player has joined.

On the second Mac, I go into Multiplayer -> LAN -> Join Game, and the game from the first Mac correctly shows up:

# HOST
1. my name Race

So I click Select, and the little satellite dish icon sends out waves, but after a few seconds, an error message pops up "This game session is no longer available."

After pressing Esc, the game from the first Mac definitely still shows there, and even if I "Refresh", it's still there.

I would be really grateful if someone could help me fix this - Flatout 2 is the absolute best, awesome car game I've ever played and with multiplayer it would be incredible!

If it involves some work to fix this problem, like a patch, I'd be happy to pay for it - it means that much to me! Thanks ;-)
 

verindil

New Member
I figured I should post here as this was the first hit result when I googled this issue. I was running into this issue and found a way to make it work.

Just a warning: This may be a bit technical but hopefully it can help some people down the road continue to play this amazing game.

First off I don't think that the problem that you are having is related to running the game on a MAC, it sounds like it is a problem with a setting on your router.

Troubles seeing a LAN server:

This game uses a UDP broadcast to send info about the server and so other computers on your local network can "see" the server.
Possible Causes
1.
Your Network Interface (Wifi adapter, Ethernet Adapter... basically the things you use to connect to the internet/LAN) is sending the broadcast/the game is listening for broadcasts on the wrong adapter. UDP broadcasts like to go out on a single Interface and one that has highest priority, easiest way to fix this is to disable all other network interfaces that you are not currently using and restart the game. If you NEED more than one then you can google how to make one have higher priority as that depends on the operating system you are running.
2. Your Local or router firewall is blocking the UDP broadcast... or blocking SSDP (Simple Service Discovery Protocol) this is not usually the case but it can happen and I can't describe how to fix this as it depends on your router/operating system
3. You do not have a route to the server, in windows run (nslooklup THE_IP_OF_THE_SERVER) to see if you can resolve the machine's name and after that there should be a cached route and the game can pick up the server broadcast. If nothing comes back then you have a bigger problem that can be solved, just not here :(

Getting the Error "This game session is no longer available":
I have only identified a single cause of this issue and it is all related to UPnP (Universal Plug and Play). So this game uses UPnP to connect to the server. Many Routers and firewalls block/disable UPnP out of the box as there are some security vulnerabilities with it. So in order to fix this make sure that your router has UPnP enabled and if your router has specific controls for access to UPnP make sure that the IP of all machines that want to connect are allowed to use it. Again I cant go into details of how to enable this as it depends on your router... do some googling and I am sure you can find out how.

Hopefully this helps someone in the future, a post like this could have saved me a good amount of time digging for a solution.

Happy Racing!/Crashing!/Stunts? :)

-Verindil
 

FlatOut2OnMac

New Member
Hi Verindil,

thank you so much for replying - much appreciated, because 2 years after my original post, Flatout 2 is still my favourite game!

I have a Huawei HG659b - I had a look through all the settings pages, I couldn't find anything UDP-related. Both Macs are connected to the router via ethernet cable - the only things I could think of was:
1) Firewall level (set to Low, which according to the documentation means "all active packets from the LAN to WAN are allowed"), so that's not going to affect anything within the LAN I would have thought.
2) Dynamic DNS (DDNS) - not enabled, but again I can't think how this could be relevant.
3) Multicast Management
I've never changed this - the default settings are "Enable IGMP proxy" ticked, WAN connection "Auto", and "Enable MLD proxy" unticked. Again, I believe this is only relevant for LAN to WAN, i.e. internet, but please tell me if you think otherwise.
In the LAN settings, there's nothing interesting - I do have uPnP enabled, but as far as I understand that's really only for discovery when a new device joins.

I would be seriously appreciative if someone finds a solution, heck I'd even be willing do pay a bounty via Paypal! ;-)
 
Top