How can I install mods for FlatOut 1 on Steam?

BugCar93

New Member
Has anybody bought FlatOut 1 on Steam, and installed the car mods from these 3 videos?

1)
2)
3)

If anyone has, can you help me with how to install them? And can you include a video tutorial, please?
 

Purple44

Well-Known Member
Team Bugbear Member
The Steam version of Flatout 1 is v1.0, unpatch. Need tp patch to euro v1.1 to run mods.

Could install our FOv3 mod which has the v1.1 patch file in the download:

Heddly said:

Some the cars in the 3 videos:

Shelby GT500E - can't help with this car
Heddly late model - have to ask Heddly if he got download link
Buick GTS - can be found in Heddly carpack for FOv3 community mod


Here thread with link to Heddly car pack: Carpack for FOv3 Community Mod for Flatout 1

You also might want to check out this other car pack Heddly did for Flatout 1: MCO-MOD_FOV3_Addon


Flatout 1 can only load an extra 16 custom cars. Flatout 1 can only handle 32 cars without crashing.

Archives = {
[1] = "FOV3-Patches/fov3.bfs",
[2] = "FOV3-CustomCars/HeddlysFOV3Pack.bfs",
[3] = "FOV3-CustomCars/Hedllys_FOV3_CP2.bfs",
[4] = "FOV3-CustomCars/5buickgtsfov3.bfs",
[5] = "FOV3-Patches/fov3overrite.bfs",
[6] = "FOV3-Patches/fig8 track pack.bfs",
}


Any custom car(s) you want load with FOv3 mod, need to be listed between "FOV3-Patches/fov3.bfs", and "FOV3-Patches/fov3overrite.bfs", for custom car to load properly.

Also need a good cars.ini file for the cars you are loading:

car=5
name=BUICK GS455
image=car3a.tga
class=3
colors=40,60,33,53,25,45,36,56,28,48
-----
car=32
name=70 Chevelle
image=car3a.tga
class=3
colors=21,41,22,42,23,43,24,44,25,45
-----
 

Attachments

Heddly

FOJ Supporter/Modder
Team Bugbear Member
I found more FlatOut cars that are in your videos. If you get the FOV3 Mod working I can share the links for them. :)
 

BugCar93

New Member
Here's an update. I dowaloaded the link from Purple44's comment, and followed the video from it. But now, when I click on the app to start the game, I keep getting this thing that asks me to "allow this app from an unknown publisher to make changes to yuor device."



Whenever I click yes, it dosn't start the game at all, but when I click no, it stops the game startup process. I can't play the game at all now. I tried uninstalling the game from my Steam library and reinstalling it, and I even removed the game completely from my account to buy it all over again to try restarting from scratch, but nothing changed. Btw, when I first installed the mod launcher, it kept giving me a lot of messages asking me to replace some game files with the same thing with higher amounts of bytes, and I clicked yes for all of them. But now after all of this, I can't start the game at all. I don't know what to do now.

Has anybody else had this problem?
 

BugCar93

New Member
"v1.0 can run fine under Win10, it the euro v1.1 having the issue?

Yes, that was my case. The game worked fine for me in Windows 10 as a regular game, but not when the mods were added.

Well, this sucks. I was so looking forward to all those classic American muscle cars; the 1967 Shelby GT500, the 1967/69 Chevy Camaro, etc. Especially the 1969 Charger, and especially its General Lee livery.


I guess I have to either figure out how to fix this, or install Windows 7, and run the whole game, mods and all, under that?
 

Heddly

FOJ Supporter/Modder
Team Bugbear Member
BugCar93 said:
Here's an update. I dowaloaded the link from Purple44's comment, and followed the video from it. But now, when I click on the app to start the game, I keep getting this thing that asks me to "allow this app from an unknown publisher to make changes to yuor device."



Whenever I click yes, it dosn't start the game at all, but when I click no, it stops the game startup process. I can't play the game at all now. I tried uninstalling the game from my Steam library and reinstalling it, and I even removed the game completely from my account to buy it all over again to try restarting from scratch, but nothing changed. Btw, when I first installed the mod launcher, it kept giving me a lot of messages asking me to replace some game files with the same thing with higher amounts of bytes, and I clicked yes for all of them. But now after all of this, I can't start the game at all. I don't know what to do now.

Did you click, "Show More Details"? It may help. I don't have win10 but you may try copying your game files to another folder outside of Steam, run as Admin and use Compatibility Mode in Win7. Just a thought, Steam may be blocking the FlatOut.exe file?

Has anybody else had this problem?
 

BugCar93

New Member
Were you trying to tell me something after quoting my reply? Because I saw nothing from where you would type your comment.
 

Heddly

FOJ Supporter/Modder
Team Bugbear Member
Sorry about that,I don't have Win10 but I found this on Zmod forum to fix Zmod1 to run on Win10.

Make a copy of the game folder outside of the Program folder , like C:\FlatOut, . Right click the flatout.exe and look for compatibility mode, click Win7, click ok and then right click the .exe again and select Run as Administrator.
 

BugCar93

New Member
Heddly said:
Sorry about that,I don't have Win10 but I found this on Zmod forum to fix Zmod1 to run on Win10.

Make a copy of the game folder outside of the Program folder , like C:\FlatOut, . Right click the flatout.exe and look for compatibility mode, click Win7, click ok and then right click the .exe again and select Run as Administrator.
I tried it a bunch of times. It didn't work for crap. I even selected Windows 8, 7, AND XP (Service Pack 3).
 

Heddly

FOJ Supporter/Modder
Team Bugbear Member
You may have read this topic FlatOut v1.1 Patch for Steam & GOG and I hope it works for you.

These are some links about FlatOut and Windows 10 that I found on PC Gaming Wiki - FlatOut

SafeDisc retail DRM does not work on Windows 10[2] and is disabled by default on Windows Vista, Windows 7, Windows 8, and Windows 8.1 when the KB3086255 update is installed.[3]

SafeDisc DRM[Note 1]. Use the official Russian executable to bypass (see Flatout (Un)official Russian 1.1 patch

Not Loading in Windows 10; this will break thousands of - Microsoft Community - last accessed on 2017-01-16

Flatout - Wrong version fix (GOG/Steam) 1.1

This file has been reported as broken because: I get a runtime error once the game reaches the splash screen, can't figure out why this happens.
The GOG and Steam versions of Flatout use a version 1.0 executable; you cannot turn the ragdoll feature off with version 1.0, and you won't be able to create LAN games without a version 1.1 executable because the other files were patched to 1.1. The retail version of the game shouldn't have this problem. Extract the proper executable into the game directory overwriting existing files.
This file was extracted from the official Russian patch installer (http://www.buka.ru/cgi-bin/show.pl?id=143&option=Show_patch) using UniExtract.
 

TheMan2010-13

When sparks fly, mayhem is coming...
Full time wrecker
Heddly said:
You may have read this topic FlatOut v1.1 Patch for Steam & GOG and I hope it works for you.
Definitely use this download for the v1.1 version. The one currently on PCGamingWiki doesn't have the two important files being patch1.bfs, and patch.ini, so I included those 2 files, and it now works with the Steam version, untested with the GOG version.

Once my file gets approved on PCGamingWiki, I'll make sure to remove the links going to the broken mod, and replace them with my patch. Thanks for the mention, Heddly!
 

BugCar93

New Member
Gamer Alex (AlexKVideos1) said:
Heddly said:
You may have read this topic FlatOut v1.1 Patch for Steam & GOG and I hope it works for you.
Definitely use this download for the v1.1 version. The one currently on PCGamingWiki doesn't have the two important files being patch1.bfs, and patch.ini, so I included those 2 files, and it now works with the Steam version, untested with the GOG version.

Once my file gets approved on PCGamingWiki, I'll make sure to remove the links going to the broken mod, and replace them with my patch. Thanks for the mention, Heddly!
It's like my game doesn't want to work for me. Because when one solution gets fixed (thank you all, by the way, for helping me), another problem comes up that prevents me from starting my game. Because now I have ANOTHER message popping up. You know about the one that comes up for yes or no to "allow this app from an unknown publisher to make changes to your device." And now after clicking yes, I actually get ANOTHER game failing message, which now says "File 'data/language/version.ini' not found from the file system."

Man, what more do I have to do to make my game run properly?

 

Purple44

Well-Known Member
Team Bugbear Member
Rocket455Man [FIN] said:
Hi!

Will flatout work with win 7 64-bit?
Flatout 1 and Fov3 mod ran fine under Win 7. :)

***********************

BugCar93 could you paste your filesystem.ini and patch.ini files into a post so we can see what you are loading? Also you trying load stock v1.1 Flatout or Flatout modded version like FOv3?

filesystem.ini:

Archives = {
[1] = "common1.bfs",
[2] = "common2.bfs",

}


patch.ini:

Edit: Hmmm, looking at pic, your Flatout.exe look to small.

My noCD EU v1.1 Flatout.exe is 4,401 KB. Don't know how big stock v1.0 is. I have US v1.2 Flatout.exe that is 5,362 KB.
 

Purple44

Well-Known Member
Team Bugbear Member
Also if trying to load the FOv3 mod, you should leave your stock Steam Flatout folder alone, and create a \FOV3 mod folder to copy common1.bfs and common2.bfs files and the Flatout.exe EU v1.1 file you got to work under Win10, to the \FOV3 mod folder and unpack FOv3 mod files there.

Heddly Gold FOv3 mod come with the noCD EU v1.1 flatout .exe that does not work with Win10. :(
 

Heddly

FOJ Supporter/Modder
Team Bugbear Member
Purple44 said:
Also if trying to load the FOv3 mod, you should leave your stock Steam Flatout folder alone, and create a \FOV3 mod folder to copy common1.bfs and common2.bfs files and the Flatout.exe EU v1.1 file you got to work under Win10, to the \FOV3 mod folder and unpack FOv3 mod files there.

Heddly Gold FOv3 mod come with the noCD EU v1.1 flatout .exe that does not work with Win10. :(
I think the Flatout.exe EU v1.1 file that works under Win10 should be be the last step to make sure it is not overwritten by the files in the FOV3 Gold Edition.

I think that copying the common1.bfs and common2.bfs files and then installing the Gold FOv3 mod with the noCD EU v1.1 flatout .exe that does not work with Win10 and then Flatout.exe EU v1.1 file you got to work under Win10, would prevent the "noCD EU v1.1 flatout .exe that does not work with Win10" from over writing the "Flatout.exe EU v1.1 file that worked under Win10"?

edit - Sorry for rambling, I tried to make as much sense as I could with what little I have left. :)
 

Purple44

Well-Known Member
Team Bugbear Member
Ya Heddly you right about over writing the flatout.exe, want to end up with the Flatout.exe that works with Win10 in FOv3 mod folder!
 
Top