Slow change from N -> 1st gear w/o clutch

St. Jimmy

Finland
Full time wrecker
It looks like this could be the reason for clutch users having advantage on starts.

N->1st gear it's almost like the clutch doesn't work right and the gear engage time takes forever. Almost like the gear is changed raw. It happens all the time, not just at the race starts.

No other gear or direction has any noticable delay. Even N->R works well. N->1st is the only issue every single time.

You've said that clutch having advantage is "intended" but looking at this behavior it looks more like a bug than feature.

Every somewhat competive racer in this game would like to see the clutch start advantage disappear.

 

St. Jimmy

Finland
Full time wrecker
What kind of a controller and to what is the clutch mapped to?
Keyboard and using manual so clutch shouldn't matter.
In the video there's a mod that makes manual gear changes much faster so it's easier to see that there's an issue with N->1st but the same delay is there even without the mod.
 

St. Jimmy

Finland
Full time wrecker
Checked from the recording how long the N->1st takes just out of curiosity. It takes around 0,7s for the gear go to N->1st.
 

Janne Suur-Näkki

Administrator
Staff member
Do you mean the time it takes for the gear to change, or the time it takes it to engage?

On the video it looks very buggy when it keeps switching between N and 1, not sure I've ever seen that happen during normal gameplay.
 

St. Jimmy

Finland
Full time wrecker
The time it takes to engage is high.

Like you can see how long the gear indicator is gray. The gear changes but it's like the clutch is pressed looong time and the car revs.

The interesting thing is that from N->R it's not buggy.

I can post another video at around midnight :p
 

Janne Suur-Näkki

Administrator
Staff member
Yes, that's what I thought too but wanted to double-check.

It's most likely caused by something called "launch clutch" that we have, and while it can be adjusted per-engine, it's a tricky thing to tune properly since too little clutch slip easily means that the engine might bog down (not enough torque) or just break the traction instantly, leaving you spinning the wheels (too much torque).
 

St. Jimmy

Finland
Full time wrecker
Here's video without the mod. Also Testing N->R. That's fast even at the start.

Also thanks for the hint for the launch clutch. Will do some tests in the weekend.
 

Janne Suur-Näkki

Administrator
Staff member
Thanks for the video, there's indeed some sort of an odd delay. Will investigate whether it's something we can improve on.
 

St. Jimmy

Finland
Full time wrecker


We tried the launch clutch tuning. It's like 0.6-0.7 start and 0.9 end per car as seen on the above picture.
Making it 0.1 start and 0.2 end is working well on many cars and starts are more balanced.

So I suggest that you lower it a lot.
 

St. Jimmy

Finland
Full time wrecker
Left one is modded X=0.1 & Y=0.2
Right one is default X=0.7 & Y=0.9

And another video about the same thing. Last run is the non-fixed version:
 

St. Jimmy

Finland
Full time wrecker
Fix this next? This is THE reason why so many use the clutch in the first place.

Fixing it and many 'manual with clutch' would move back to 'manual'.

When you lose 0,7s at the start, it means that many cars pass on the start 5-8 cars, which means it's actually not 0,7s penalty but you loose 5-10 SECONDS minimum. The harder to pass the guy in front, the more time loss so it could be like 20s penalty for a short race...
 

labbe-

New Member
In the new update they fixed it.. Dont know how much because I still feel little delay on clutch but its far better than yeasterday! :)
this thread is about the delay between neutral and 1st gear when you are using manual without clutch :p completely unrelated to the changes made to digital clutch
 
Top