Hot Fix Update 2014-23-10

Jori Virtanen

Automatic weapons and boundless love.
Hey all y'all!

We released another hotfix for Wreckfest yesterday, as many of you have already noticed. Here's the change list:

Update #6 Hot Fix #6 - 24/10/2014
  • Fixed camera getting stuck to the side bug.
  • Support some more exotic characters in player names.
  • Added KM/H / MPH speed display toggle to Display Settings.
  • Added show / hide player names toggle to Display Settings.
  • Show per-class best lap time in event selection.
  • Fixed multiplayer bug: remaining time not updating in results window when spectating.
  • Fixed multiplayer bug: if the race started when player was in the game or settings menu, the mouse got hidden, thus making it hard to close the menu windows.
  • Reworked lobby chat, includes scrollbar
  • Improvements to joining handling
  • Improved client-side prediction
 

Lari Fari

Gaming Since 1989
Yes! Awesome! Gave it a little try yesterday and it sems to work alright! Chat is much better now!

One question: What does "Improvements to joining handling" mean? :)

Cheers, Lari
 

Dillinja187

Member
Thanks for update guys, like Lari I gave it a little spin last night and yes chat seems much more solid which is great news :)..

I cant really speak about other changes as I only hit it for 2 hours which is not really long enough to get good feedback.
 
Lari Fari said:
One question: What does "Improvements to joining handling" mean? :)
Joining should be faster and fail less. It should also give a reason for more problems in a message box instead of failing silently.
 

Lari Fari

Gaming Since 1989
Ah OK thanks! I was thinking "handling" as in "handling of the cars" :D

Good to know. And I think its true. joining did happen a little easier yesterday and I didn't get any errors :)
 

Dillinja187

Member
I've got to say after playing/hosting more I do find it slightly less stable, for sure had more .exe crashes than before hotfix and more errors hosting just had 1 now which sparked this off :)

Tried to host as normal clicked create and said " already logged in " was an option to retry but it locked solid (alt F4 to kill). Had similar problem on previous hotfix build but got an option to retry and it normally sorted itself :). This also normally happened if u were too quick to try and host between games but again click retry boom you were in on previous build.

Its only happened twice so its no game breaker, Just knocking it into the park that's all :)

I had once the game engine go into safe mode locked @ 30fps and didn't recover - normal is vsync on and 60fps everywhere (maybe a lag spike that caused low fps in the 1st place and it just didn't recover ?)
 

Antonio001z

New Member
Hi there thank-you for the consistent updates, I am an AUS host for next car game and rely on the kick function to ensure that my races dont suffer from terrible lag, however it has been removed in the latest update could you please put it back so myself and all of my friends can get back to playing thank you.
 

Majatek

Posts generated by this user derive from consensus
Full time wrecker
Master Blaster
Team Bugbear Member
Neat! Any word on a server tool for Wreckfest? I wouldn't mind hosting for my Australian buddies, but I'd rather do it on a separate machine rather than having to run Wreckfest.
 

FollowWings

There is nothing impossible just laziness!! ;-)
Full time wrecker
Works like a charm! Thank you BugBear! ;-)
If anyone detect some issue after the hotfix, could a reinstall solve the problem! ;-)
 
LUNITIC_WILL said:
so does this mean that i won't have to restart the game to reset chat so i can type?
Yes.

Antonio001z said:
Hi there thank-you for the consistent updates, I am an AUS host for next car game and rely on the kick function to ensure that my races dont suffer from terrible lag, however it has been removed in the latest update could you please put it back so myself and all of my friends can get back to playing thank you.
Will be fixed soon. It got broken when the chat was redone and we forgot to test it since not much need for kicking in the office LAN. :)
 

St. Jimmy

Finland
Full time wrecker
Tapio Vierros said:
Antonio001z said:
Hi there thank-you for the consistent updates, I am an AUS host for next car game and rely on the kick function to ensure that my races dont suffer from terrible lag, however it has been removed in the latest update could you please put it back so myself and all of my friends can get back to playing thank you.
Will be fixed soon. It got broken when the chat was redone and we forgot to test it since not much need for kicking in the office LAN. :)
I guess today's patch fixed this?
 

juggermalt

New Member
Weeked Smasher
Tapio Vierros said:
Will be fixed soon. It got broken when the chat was redone and we forgot to test it since not much need for kicking in the office LAN. :)
Thank-you for getting onto this so quickly, much appreciated from all of Australia! :D
 

Antonio001z

New Member
Thankyou for sorting out the kick issue so quickly, also where can i take my suggestions?? i have an idea for a great game mode
 

Majatek

Posts generated by this user derive from consensus
Full time wrecker
Master Blaster
Team Bugbear Member
Feel free to post that idea to the Game Design subforum (be sure to search for whether there may already be a thread about it though! It helps if we consolidate threads that have the same ideas as it makes it easier to keep track of all of them). :)

http://community.bugbeargames.com/index.php/board,27.0.html
 

Dela

Member
Weeked Smasher
Maybe for next update try to improve performance when you play multiplayer

I did some testing on lowish settings ( because multiplayer doesn't work on high) and here are my results for figure 8 track

16 players on multiplayer figure 8 track

Avg: 80.706 - Min: 62 - Max: 133

15 ai cars + me on single player

Avg: 130.982 - Min: 71 - Max: 265

also even in the lobby room frame rate halves when people come back from racing ( well actually it even dips to 5 or so momentarily )

If i try to use higher settings that work fine on single player ( not all of them shadows kill my fps) i get something like 25 on multiplayer and 70 on single player (average)

I have seen similar issues on all servers but it's worse on figure 8 and oval track

Why is that and are you planning on improving that ?
 
M

Miau

Guest
this game getting better and better, thx for updates, hope it will be final soon ^^

i ve some problems with wreckfest, i dont like the antialiasing, its somehow strange, and my eyes hurts x.x
i cant set antialiasing in my driver options, only game antialiasing works o_O and it looks like gta4, i ve a r7 260x

and other problems, there are lags in game its sometimes like i m driving against a wall in multiplayer and i cant host
i think its problem of my router, must open ports, but i m to lazy, hope you can fix that too :D

saving of car tunning would be great, if i restart the game the tunning options are reseted ^^''
 

rauf00

Member
Lot of positive changes, happy to see that Next....WRECKFEST is coming in right direction. 8)

FOV regulation, nice FFB and look rear make it again very playable, thanks Bugs!
 
Top