Hotfix 2015-07-03

Janne Suur-Näkki

Administrator
Staff member
Another hotfix for Wreckfest is out, addressing a number of issues found in the game. The update also contains an experimental fix for the issue with mapping controller inputs; please do let us know in case the bug is fixed for you or if you still experience it.

IMPORTANT NOTICE:

Before joining a multiplayer game, it's always a good idea to revert the networking settings back to default in the game's settings menu. In case you experience bad multiplayer performance you can try lowering client prediction time, but lowering it too much will cause glitches such as cars warping, rubberbanding, etc. so experiment with care.

In case you experience any random issues like being unable to map controller inputs or duplicate upgrades, please first try removing the user data generated by the previous game versions by navigating to [STEAM INSTALLATION FOLDER]/userdata/[USER ID]/228380 and removing the entire folder. The default Steam installation folder is 'C:\Program Files (x86)\Steam'.

As always, thanks for your support!

Please find the changelog here:

- Fixed scrolling with mouse wheel.
- Fixed imperial units in user statistics, car info and HUD.
- Fixed multiplayer race start occasionally getting stuck.
- Disabled controller hotplugging to test if it caused mapping problems.
- Disabled wrong way speed limiter in single player.
- Fixed e-brake for all cars.
- Removed duplicate stock brake upgrades.
- Fixed European Coupe 2 engine name.
- Fixed incorrect gearbox names and added descriptions.
- Fixed American Sedan's windows going black when damaged.
- Improved gamepad controller to make counter-steering easier.
- Fixed AI behavior at race start.
 
Good job with the gamepad fixes. I need better recording software and mixing but here's an idea of how much better and smoother it is (its not the game running choppy its the recording itself). This wouldn't really be something I could pull off if it wasn't running properly anyway.


While they're hard at work with hot fix after hot fix anyone wanna recommend me a better recording program? (or help me figure out how to get better video/sound quality using Xsplit)
 

Sparky

New Member
Still not able to assign buttons with the Logitech G27. Only the DPad works.

Edit: Found my issue with the G27. I have a PPJoy device installed and when I disable that, AND REBOOT, startup Wreckfest, I can then rebind buttons on the G27 (except Button16). I can do this in my old config (from Build6) and with a new config(Build7).
As soon as I enable the PPJoy device again, I lose the ability to edit the G27 button binds (axis and DPad still work).

I also tried, in Windows Game Controllers > Advanced, and changing the primary/use with older programs option to both the G27 (default) and the PPJoy device, but still had the issue of not being able to edit G27 buttons.

I have been using PPJoy 0.84.6 for a long while now with no ill affects in other games or previous versions of Wreckfest AFAIK.
 

Janne Suur-Näkki

Administrator
Staff member
Nice Glasses
Thanks for the nice video, it's exciting to see we're definitely getting closer to what we want.

Sparky
That's really too bad, but thanks for letting us know. We'll continue investigating the issue.
 

Holybeer

Member
I don't know if it's me but before this update, cars were too grippy, now, I spent all my corners drifting.
 

Aï_DweN

New Member
Thank you Bugbear for this update, we hope to have soon the reverse on multiplayer.
And an improvement in the physical.
 

The Very End

Well-Known Member
Weeked Smasher
Master Blaster
Is the contact physics "final", or are they still up for tuning? The driving feels good, but the cars just seem a tad heavy when crashing. The flipping and all the other craziness from previous builds suited the chaotic atmosphere of the game :)
 

Adziej

Member
Weeked Smasher
Please Bugbear
1. Fix the handbrake, still not working for me.
2. Mapping buttons on controllers still doesn't work - only DPad and analogs work (but keyboard and xbox 360 wireless gamepad is fully configurable - even buttons, triggers, shoulders etc.)
3. Game seems to crash sometimes, crashed once when trying to configure buttons on xbox 360 gamepad.
4. Visual damage of the cars should be improved.
5. I feel no power when driving, game is a lot slower, don't like it at all. :(

Oh, and forgot to write that I use only DX9 for now. I don't like experimental and unstable stuff. :p
 

rwb

Member
Weeked Smasher
Sparky said:
Still not able to assign buttons with the Logitech G27. Only the DPad works.

Edit: Found my issue with the G27. I have a PPJoy device installed and when I disable that, AND REBOOT, startup Wreckfest, I can then rebind buttons on the G27 (except Button16). I can do this in my old config (from Build6) and with a new config(Build7).
As soon as I enable the PPJoy device again, I lose the ability to edit the G27 button binds (axis and DPad still work).

I also tried, in Windows Game Controllers > Advanced, and changing the primary/use with older programs option to both the G27 (default) and the PPJoy device, but still had the issue of not being able to edit G27 buttons.

I have been using PPJoy 0.84.6 for a long while now with no ill affects in other games or previous versions of Wreckfest AFAIK.
Well well, when I read this I tried unplugging my TH8 before starting the game so only game controller was the wheel, and can now map buttons. Downloaded hot fix and wasn't able to map buttons before doing this, did delete the cache folder.
 

conso1727

From Italy
Full time wrecker
A question for Janne, if he will read this. The new speedway will also get the inner oval and figure of 8 layouts?
 

Dillinja187

Member
Janne Suur-Näkki said:
Nice Glasses
Thanks for the nice video, it's exciting to see we're definitely getting closer to what we want.

Sparky
That's really too bad, but thanks for letting us know. We'll continue investigating the issue.
Sweet !, definitely getting somewhere closer now :). the drift feel much more controllable on a controller now and the weird bonnet and bumper cam bug has gone for me aswell (camera flicking up every 20 secs or whatever) as reported here also the button map issue still remains for me. Great work on this hotfix keep em coming and thanks for your hard efforts.
 

Adziej

Member
Weeked Smasher
WorldofBay said:
Adziej said:
5. I feel no power when driving, game is a lot slower, don't like it at all. :(
have you tried to change the FOV offset like mentioned here?
Yep, playing with +15 but still it's a problem with car's speed. All of them seems sluggish and too heavy comparing to previous build. Maybe it's just me but not enough speed means less fun. :(
 

orbotnive

Member
Adziej said:
Yep, playing with +15 but still it's a problem with car's speed. All of them seems sluggish and too heavy comparing to previous build. Maybe it's just me but not enough speed means less fun. :(
I get it too, the cars have all been reduced a little but also I've realised that I can't play in the resolution I used to. Shrinking it down with FOV 30 and lowest settings on pretty much everything makes it 'ok' for me but still not quite what it used to be. 1.5GB gfx is too low now :/ Anyway thanks for the fix, I like the changes.

It's a big difference though! When on max assists before hotfix I could just barely keep control most of the time. Now it's almost easy, and then I realised that all assists were off :eek: I'll have to try with them on for a laugh

I'm not complaining, just had a race in multiplayer, it's good to feel back :)
 

happyrichie

Member
what is wrong with you people! the game is terrible and this fix makes it worse! i can drift the whole large fig 8 track, where is the grip?!? i didnt realize this was a drift game. their is no grip with the torque curve, its easier just to drive flatout in a gear and that grips better than the top of a torque band.

360 pad, why ow why do i have to map indivdual gears because the gear change is soooo god dam slow, why cant i double tap down shift and go from 3rd to 1st, why with the custom mapped gears do i have to hold the gear button or the gear falls into neutral?!?

why is reverse driving handicapped? if servers want no rules let them!! just add it as an option for online.

im on a 960 4gb, 8320e, 16gb ram, windows 7 64 bit, why cant i run 64 bit, it refuses to load, why when more than 10 cars hit the track does my fps drop to 10 with low settings? i was playng close to max settings on the old version on a 660 2gb, how did you screw this up so bad?!?

cars are to rigid, their are no clown heads in the boots that come flying out in a crash, their are no blimps, caravans or horses.

i havent down rated this game on steam yet cause i figure ill give them some time, but this patch is real bad, the new build needs lots of work and this isnt the game i bought, it has been changed and i expect better :'(

talking to people i am yet to hear anyone say they are impressed by what you have done
 

conso1727

From Italy
Full time wrecker
I got to agree, the multiplayer backwards speed limiter should be removed.
EDIT: Well, maybe removing is too much. Lobby setting is the way.
 

danthed

New Member
The game performance is really bad in multiplayer also with a good ping... its not much better solo, in fps its around 10fps faster and kind of playable but not perfect.

In multiplayer its mostly somewhere around 10fps, sometimes i have 20fps -yeah :) I think it depends on the number of cars playing and cars crashing :). My hardware is nvidia 660m, i7 2,4Ghz and 16GB RAM, uptodate drivers. I checked the task manager, my cpu runs fine with 20%-30% using 6GB RAM. But my graphiccard is doing alot and becomes realy hot, like never before... By the way, i disabled and lowerd all graphic settings to the minimum avaiable! Network is runing smooth. Standard Value of the Network Prediction Time is 800ms and I cant lower it from that with the slider. I increased it now, but it doesent change the performance. In my case I think it has not much to do with network tweaking.

I hope you can optimize the performance soon, because now its not playable for me and I realy hope its not intend to use a SLI
 

MSPORTBMW

Member
Master Blaster
danthed said:
I hope you can optimize the performance soon, because now its not playable for me and I realy hope its not intend to use a SLI
Well i for 1 hope the game will utilize SLI in the future.
 
Top