Hotfix 2015-07-07

Janne Suur-Näkki

Administrator
Staff member
The latest hotfix for Wreckfest is now out, addressing multiple major and minor issues as well as increasing performance especially in multiplayer. We're pretty confident that the issue of being unable to set up multiple controllers has now been fixed – please let us know in case you're still experiencing issues.

IMPORTANT NOTICE:

Before joining a multiplayer game, it's always a good idea to revert the networking settings back to default in the game's settings menu. In case you experience bad multiplayer performance you can try lowering client prediction time, but lowering it too much will cause glitches such as cars warping, rubberbanding, etc. so experiment with care.

In case you experience any random issues like being unable to map controller inputs or duplicate upgrades, please first try removing the user data generated by the previous game versions by navigating to [STEAM INSTALLATION FOLDER]/userdata/[USER ID]/228380 and removing the entire folder. The default Steam installation folder is 'C:\Program Files (x86)\Steam'.

Please find the changelog here:

- Fixed DirectInput controller input mapping (please reconfigure your controllers).
- Temporarily disabled Alt-Tabbing on DX11 on prevent the game from dying.
- Improved multiplayer performance.
- Improved performance of dynamic objects.
- Reduced dedicated server CPU load on empty servers.
- Fixed lobby displaying wrong car class and performance index for some cars.
- Fixed loud player engine sounds in replay/spectate when not targeting or near player car.
- Fixed car body and wheels disappearing after being damaged while the player is in bumper cam.

Thanks for your support and feedback!
 

SRV

New Member
Nice, thanks for this update :)
You forgot to mention that cars grip is better now.
 

TH8

Active Member
Yes, this update is great...can map all my controllers, T300RS, 2x TH8rs Shifters (1 set up for Handbrake, 1 set up for H-Pattern Shifter), and a Button Box....BUT still getting a lot a lag in the Steering, Acceleration, Braking, Changing Gears and using the Handbrake...it's like everything is happening in slow motion with the controllers, game play seems fine. I have adjusted the Saturation etc settings trying out a lot of variations and have improved it slightly but the lag is still there.
Really liking the look, feel and the sound so far...keep up the good work.
regards
TH8

EDIT: Have reduced most of the settings in Display to 'Low' and this has improved controllers response time a little more but the lag is still there...especially in the gear change and steering.
 

OutLoud

New Member
Still crashes at splashscreen for me, all versions. Is there no error log or something i can give you so that you can investigate? Should I delete and reinstall?
 

Roller

New Member
OutLoud said:
Still crashes at splashscreen for me, all versions. Is there no error log or something i can give you so that you can investigate? Should I delete and reinstall?
Did you try this:

In case you experience any random issues like being unable to map controller inputs or duplicate upgrades, please first try removing the user data generated by the previous game versions by navigating to [STEAM INSTALLATION FOLDER]/userdata/[USER ID]/228380 and removing the entire folder. The default Steam installation folder is 'C:\Program Files (x86)\Steam'.
 

OutLoud

New Member
Roller said:
OutLoud said:
Still crashes at splashscreen for me, all versions. Is there no error log or something i can give you so that you can investigate? Should I delete and reinstall?
Did you try this:

In case you experience any random issues like being unable to map controller inputs or duplicate upgrades, please first try removing the user data generated by the previous game versions by navigating to [STEAM INSTALLATION FOLDER]/userdata/[USER ID]/228380 and removing the entire folder. The default Steam installation folder is 'C:\Program Files (x86)\Steam'.
Yes, didn't help. I'm re-downloading right now.

EDIT: Nope, still crashing.
 

Dela

Member
Weeked Smasher
Hurray performance improved quite a bit on my Amd card :)

I detected that biggest killers of fps are (still) shadows. They used to be and they still are. Turning shadows from off to low = -20fps on average.
Other big killers are grass and cube map. Other than that i can now almost max everything and get close to stable...ish 50-60fps. Also dx11 performance seems bit better now. Still not as good as dx9 but closer.

But when i tested running with shadows, cube map and grass on i noticed that although my fps dropped a lot my gpu & cpu usage increased only by 5% and gpu mem usage by 100 or so mb.
So my cpu usage was around 75-84% and gpu usage 70-80% (gpu mem 2600mb), but still my fps dropped. So i think there is some fiddling to do :p
 

Adziej

Member
Weeked Smasher
Damn still handbrake is too weak in all cars. When will I be able to lock the wheels? :/ I'm using xbox 360 controller, handbrake is assigned to X button and still I can't make any awesome drift while using it. :/
 

catn1p

Member
Thanks BB, stability is better now i guess. First I thought assists were on by default after update...

Maybe I'll be able to master locked diff now.

Also the graphics seem to run smoother, but not sure since it was good for me on 64bit since update.

Dynamic opjects are pure eye candy, went through a wheel barrier at ~130 km/h and it just exploded like a firework made of 100 tires - BEAUTIFUL!

Keep it up!
 

ztox

Member
I haven't tried multiplayer yet (I've been assuming there are too many dicks lol) and I haven't played enough to find any jarring bugs that others may have, but can I just say that this game is looking like it's going to be incredible. I'm loving the direction it's taking and after the big update the cars are now fantastic fun to drive with all assists off, muscle 3 being my new favourite.

I also love how varied the races are, you can have really tight ones but you can also have a really split pack with cars that are 30+ seconds apart. I love being involved in the mess in the middle of the pack.

It might just be me, but collisions seem a little more punishing again than you have previously made them. So thanks for that if you've tweaked that side of things ;)

This game plays like a banger racing sim at the moment and I LOVE IT <3
 

Cono

Member
Nice Glasses said:
Thanks for another good update!! :D The cars feel much more stable now
AM3 feels so much better now!
We're definitely on the right path now.
Bugbear Entertainment delivers, very nice.
 

Mortal

Member
Thanks, deleted pad configs etc

The sedan now is better in sandpit but it remains very easy without aids, too grip etc
 

F!nsku

[SNW]
Full time wrecker
My fps is still horrible. Before 30. June's update it was about average 25fps with medium settings, now with minimum settings (everything low or disabled) best fps is about 20 what I get with 10 cars.
I'm happy this is my second pc and not that powerful what my another pc is. Playing with this (old) pc with low fps is not that fun like before because fps :/

Edit: I noticed I didn't drop game's resolution.. no effect, 13fps with lowest settings.
Windows 10, AMD Radeon HD5770 (updated drivers)

Edit2: Button mapping works now! It doesn't need anymore to unplug other controls, map one control, restart game, map another control and so on :D
 

MamieNova

"Oh no he didn't!"
Finsku, Windows 10 might have a part in this. I was using it a few months ago and I remember graphics drivers were an annoyance.
 

St. Jimmy

Finland
Full time wrecker
Finsku said:
My fps is still horrible. Before 30. June's update it was about average 25fps with medium settings, now with minimum settings (everything low or disabled) best fps is about 20 what I get with 10 cars.
I'm happy this is my second pc and not that powerful what my another pc is. Playing with this (old) pc with low fps is not that fun like before because fps :/

Edit: I noticed I didn't drop game's resolution.. no effect, 13fps with lowest settings.
Windows 10, AMD Radeon HD5770 (updated drivers)

Edit2: Button mapping works now! It doesn't need anymore to unplug other controls, map one control, restart game, map another control and so on :D
Well HD5770 was MINIMUM requirement back in the first release. If you're just at the minimum specs then it many times means you can just run it but the fps can be pretty horrible. Especially when the engine is now updated and likely less optimized than before.

Try maybe older drivers?
And like MamieNova said, Win10 can also be part of the problem.
 

St. Jimmy

Finland
Full time wrecker
And about the hotfix. Well I can forget build #6 now because this is all around better now 8) Force feedback feels enough good again.
 
Top