Hotfix 2015-07-10

Janne Suur-Näkki

Administrator
Staff member


DAMAGE IS BACK ON TRACK!

We're happy to let you know that the latest hotfix for Wreckfest is now out, giving much needed love to our damage system and making it more brutal than ever before in both single player and multiplayer. The update also improves CPU performance and features a nifty workaround for those having issues running the x64 build. Needless to say, we've also put in a host of other minor fixes, details below.

Please find the changelog here:

- Improved visual damage precision and increased deform strength.
- Implemented multi-core physics optimizations and other performance improvements.
- Implemented a temporary x64 build workaround for certain GPUs.
- Re-enabled automatic controller detection.
- Fixed positive wheel steering sensitivity curve.
- NOTE! Positive steering sensitivity values now have a higher effect.
- Improved brakes and increased handbrake torque (again).
- Last Man Standing now ends if second to last car is eliminated by contact timer.
- Fixed replay mode's glitched 4x fast-forward.
- Implemented various spectator HUD fixes.
- Tentative fix for multiple copies of a player joining a lobby after a crash.
- Enabled wheel release for vehicle damage.
- Added dedicated limited slip differentials for each vehicle.
- Improved suspension setups of all vehicles.
- Tweaked gamepad controller slightly.
- Improved vehicle cameras.
- Fixed contact audio with various objects.
- Added new paint jobs for Euro Coupe 2 and American Muscle 3.
- Fixed missing surface collisions on Tarmac 1.
- Improved collision of sand mining equipment found on Sandpit 2.
- Vehicle props on Sandpit 1 no longer cause massive damage and move around.
- Improved default reference weather.

Thanks for your support and happy wrecking!
 

CLeN

Member
Weeked Smasher
DOWNLOADING !!

Happy to see the auto controller detection, had issues with it since last hotfix.

Can't wait to unleash the apocalypse !
 

happyrichie

Member
64 bit, option screen seemed to work, steam chat was beeping at me but steam overlay wouldnt work so i ctrl +esc then 64 bit is dead again... when i load into 64 bit it freezes at option menu and the textures are weird, not really showing. 960 4gb...
 

DeadMeat

Member
Weeked Smasher
64-bit version works now, the game runs much smoother ja I think the cars don't roll over in turns so easily anymore. Great patch, thanks!

Now just add more debris, just like like in the tech demo. :p
 

CLeN

Member
Weeked Smasher
After few trys, I can say I have now huge difficulties to run the game properly, even with 8 cars on track, I have frequent freezes, in both versions of the game.

So I think I will wait the next hotfix to play like before, with 24 cars and 60fps in medium.
 

MamieNova

"Oh no he didn't!"
[minor bug] AM3 gives choice between two SB400 engine, both are indicated as installed.
(also, rate went down to B155 ?)
 

Usmovers_02

Active Member
Full time wrecker
CPU optimization worked brilliantly. I can now max 60 the game in almost all situations and never drop below 45. Best of all it's buttery smooth and no hitches.
 
B

BrianUK

Guest
Brakes are WAY too strong. The last hotfix was far better - trailbraking is barely even possible and it's just lockups all the time, even at -100% brake sensitivity.

Oh, the game also runs like a sack of crap on 32bit now. More hitching than a trailer park.
 

revenge9977

New Member
I noticed an improvement on performance, but sometimes the game freezes for a sec. I think you guys can tone up the damage a little bit.
But in general, that is a great update!
 

Jake97

Member
Yeah damage is much more better but could do with a little more imo and the game does not run as good as i used to before this update but hopefully you on the case. Good work guys
 

kennta340

Member
Full time wrecker
Server performance is preatty unstable, I have around 50-60 fps befor now I go around 10 and the game is unplayable...
 
B

BrianUK

Guest
BenDover said:
Server performance is preatty unstable, I have around 50-60 fps befor now I go around 10 and the game is unplayable...
And when you joined the server it seemed to destabilise the hell out of it.
 

kennta340

Member
Full time wrecker
BrianUK said:
BenDover said:
Server performance is preatty unstable, I have around 50-60 fps befor now I go around 10 and the game is unplayable...
And when you joined the server it seemed to destabilise the hell out of it.
I think that was becuse I got really bad fps drops and the hole game was flying to the moon with my computer or something :S
 

Hunter

Member
Getting quite a few lag spikes in multiplayer now, think it might be when there is lots of crashing going on..not sure though.
In 1 race on speedway 1 oval there was about 3 or 4 big lag spikes just on the first corner.

The fps counter on shadowplay isn't dropping when I get these lag spikes, so don't think it is related to my computer itself.
Though I have had a couple of big fps drops with this hotfix, had none at all with the previous hotfix. but these fps drops didn't coincide with the lag spikes.

Really liking the visual damage though, completely squashed some cars already :D
 

duggy

Member
my frame rate has dropped from 50fps to 25fps. Ive had to lower my graphics to have any chance of playing. Not a good hotfix IMO. This is the only game that I have to set all my graphics to low and shadows to off
 
Top